Finally pulled my head and LOL - Page 2 - KawiForums - Kawasaki Motorcycle Forums
LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 11-27-2012, 08:55 PM Thread Starter
Steel's Avatar
Join Date: Jul 2012
Location: Gainesville, FL
Posts: 240
^ old thread, see the post above yours. But yeah, the rings were absolutely gone. The valves, well, that was debatable. The exhausts were fine, but most of the intake valves were outside the factory spec; although, an engine builder told me that during the engine running the pressure from combustion would increase enough to close the valves.

Either way, I dropped a new engine in it. I'm toying with the idea of modifying the old head as per the kawi racing KIT manual and rebuilding the head myself. Getting knee deep in the engine/trans is about the only thing I haven't done to this bike.
Steel is offline  
Sponsored Links
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome