Destroying my motorcycle this weekend. - Page 2 - KawiForums - Kawasaki Motorcycle Forums
LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 11-30-2012, 08:33 PM Thread Starter
Jr. Member
WhoUtink's Avatar
Join Date: Aug 2007
Location: Clearwater, Florida, United States.
Posts: 42

The air filter is black. Crap I think it might be the original
WhoUtink is offline  
Sponsored Links
post #12 of 12 (permalink) Old 11-30-2012, 09:22 PM
Core Member
goingtoscotland's Avatar
Join Date: Feb 2007
Location: On an intergalactic cruise, in my office
Posts: 28,589
Originally Posted by Tyler33 View Post
I had an 05 and it ran fine with the ram air blocked alot worse than yours until it got cold outside (40-50 degrees). I didn't have a mesh screen over the intake either, not sure what that would help. Nice work on the build.
It just stops larger bugs/leaves/etc from entering the intake tract and airbox.

2005 ZX-10R Street and Track Whore

goingtoscotland is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome