650 Prairie Radiator Fan - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-01-2016, 11:28 AM Thread Starter
Rcf
Jr. Member
 
Join Date: Aug 2016
Posts: 2
 
650 Prairie Radiator Fan

Noticed radiator fan not working and my 2003 650 Prairie overheated. Disconnected wire from radiator bulb and connected a wire from the + side of battery and fan works. Fuse under seat is good. Can radiator bulb be checked? Are there other areas that might be causing the fan not to run?
Rcf is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-01-2016, 05:08 PM
Intermediate Member
 
BlackDog's Avatar
 
Join Date: Oct 2007
Location: Houston, Texas, United States.
Posts: 3,236
           
Not too familiar with this vehicle but m pretty sure it would be...

Fan Relay (? electrical location, probably somewhere near the battery)
or
Temp Sensor (2710A) (follow the wire to the relay)

or possible some wiring in between

You know the fan is working and the battery, so those other two items are "in between".

Good Luck Link

BlackDog is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome