New Kawi owner question - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-26-2012, 03:36 PM Thread Starter
Jr. Member
 
Join Date: Nov 2012
Posts: 1
 
New Kawi owner question

Hi all,

I just picked up a 2006 Kawasaki KX250 the bike runs fine when riding and on the throttle but has problems idling and backfires when in neutral and i give it gas. Just put a new spark plug in it and checked around the carb for air leaks. It has a full pro circuit exhaust and as far as i know it has been jetted. Could this be someting as simple cleaning the carb? please help

Thanks
kawiguy42 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-26-2012, 07:11 PM
Jr. Member
 
KawiAdrian's Avatar
 
Join Date: Jul 2012
Location: De Pere, WI
Posts: 70
   
I guess it wouldn't hurt to clean the carb and see if it helps. Not sure what else you can do, I don't have any experience with jetted carbs and aftermarket exhausts.

The views, comments, and opinions posted above represent soley the views, comments, and opinions of myself alone, and to my knowledge do not represent the views, comments, and opinions of anyone else
KawiAdrian is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome