Fuel Issues - Please HELP - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-29-2012, 09:14 PM Thread Starter
Jr. Member
 
Join Date: Nov 2012
Posts: 2
 
Question Fuel Issues - Please HELP

Hi zxr riders


I have a query that i have not seen anyone through forums online have had in the past so i really hope you can help me. i just bought this 1990 ZX250 and was running fine when i test ride it and to top it off i ride the bike home which is at least 100km from where i bought it. however, the other day i went for a ride after 10mins of riding it started surging and cut out on me, obviously no fuel was getting to the carbs.


OK, so what is happening is my fuel tap (res,on,pri) is not draining now when it is attached to the fuel line/fuel filter, however when i disconnect a hose from the fuel filter it flows fine (set on 'Pri' that is), that also goes for when i start the motor up and set it to 'RES' or 'ON' it flows fine.


NOTE: The test for the tap was when the tank's lid is closed and tells me its not an air-lock, i have also tried opening it when the hoses are connected but still no fuel flows.


So the things i have done and thought it might be is:

  • A blockage in the fuel hoses, but i have pulled all of them apart and blown compressed air and cleaned them all.
  • Diaphragm issues in the tap or the other unit by the handle bars, but it proves to work of cause as it is sucking fuel when the hoses arent connected.
  • Carb blockage, But i cleaned this and re-installed it yet hasn't fixed the issue.
  • Tank debris, but i have cleaned this also and drain all old fuel.
  • Fuel filter, Replaced and clean.

QUESTIONS:

  1. Do i need a specific fuel filter that allows a form of breathing hole to allow fuel to flow when connected?
  2. have you come across this situation before?
  3. Is there something else i need to be checking?


Anyway i may have missed some things in this email but please let me know some ideas and will be great if you know what my issue is here
NightRida is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome