Newbie with KLR650 erratic tacho and missing original decals - KawiForums - Kawasaki Motorcycle Forums
 1Likes
  • 1 Post By Sverre Houmb
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-15-2017, 10:38 AM Thread Starter
Jr. Member
 
Join Date: Apr 2017
Location: Elverum, Norway
Posts: 2
 
Newbie with KLR650 erratic tacho and missing original decals

Hi, this is my virgin thread here at the forum.

I am a 44 old male from Norway, and I recently bought a 1989 modell KLR650 with 52 000 km on it.

It had been sitting for eight years or so, and had gotten little love, so I changed the doohickey to the Eagle Mike conversion (old one was in pieces and spring broken) , overhauled the carb, adjusted the valves, changed the oil, fixed the forks, got the original flashlights back on, and got everything working that was about that.

BUT... The tacho is acting up. Itīs erratic, works pretty normal up to 4000rpms and when picking up further rims it drops. I am planning on going over the whole harness with contact spray/white grease, especially grounding, but does anybody have any other tips if that doesen`t work?

Allso, does anybody know where I can get decals for a gen.1 KLR650 Bike is white with red and blue decals and black lettering.


Sincerely
Sverre Houmb
Elverum
Norway

Last edited by Sverre Houmb; 04-15-2017 at 10:39 AM. Reason: Forgot..
Sverre Houmb is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-15-2017, 02:34 PM
Jr. Member
 
Join Date: Jan 2017
Posts: 12
 
Quote:
Originally Posted by Sverre Houmb View Post
Hi, this is my virgin thread here at the forum.

I am a 44 old male from Norway, and I recently bought a 1989 modell KLR650 with 52 000 km on it.

It had been sitting for eight years or so, and had gotten little love, so I changed the doohickey to the Eagle Mike conversion (old one was in pieces and spring broken) , overhauled the carb, adjusted the valves, changed the oil, fixed the forks, got the original flashlights back on, and got everything working that was about that.

BUT... The tacho is acting up. Itīs erratic, works pretty normal up to 4000rpms and when picking up further rims it drops. I am planning on going over the whole harness with contact spray/white grease, especially grounding, but does anybody have any other tips if that doesen`t work?

Allso, does anybody know where I can get decals for a gen.1 KLR650 Bike is white with red and blue decals and black lettering.


Sincerely
Sverre Houmb
Elverum
Norway


If the rev meeter is electronical it could help using 556 on all cable units. What you describe is normally related to dirt messing up the contact somewhere.
Zwede900 is offline  
post #3 of 5 (permalink) Old 04-16-2017, 05:03 AM Thread Starter
Jr. Member
 
Join Date: Apr 2017
Location: Elverum, Norway
Posts: 2
 
Thanks for the swift reply. I will try to go over everything with 5-56/conctact spray and white grease on grounds.

- Sverre
Zwede900 likes this.
Sverre Houmb is offline  
 
post #4 of 5 (permalink) Old 04-16-2017, 05:59 PM
Intermediate Member
 
Strider007's Avatar
 
Join Date: Nov 2010
Location: Texas
Posts: 1,674
           
Garage
Hello and welcome!

2009 ZX-6R (65,695 miles and counting) | www.ZX6R.us | www.Seaton007.com

M4 GP Slip-on | ASV C5 Levers | Spiegler SS Brake Lines | SpeedoHealer | PureONE Filter
Custom FE | Custom Blue LED Lighting | K&N Air Filter | Vortex Sprockets -1/+2 | EK MVXZ Chain
Strider007 is offline  
post #5 of 5 (permalink) Old 04-20-2017, 11:10 PM
Jr. Member
 
Join Date: Jan 2017
Posts: 12
 
Quote:
Originally Posted by Sverre Houmb View Post
Thanks for the swift reply. I will try to go over everything with 5-56/conctact spray and white grease on grounds.



- Sverre


Any luck?
Zwede900 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome