Fuel pressure problem. 2006 ex650 with aftermarket in line fuel pump - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-30-2012, 07:25 PM Thread Starter
Jr. Member
 
Join Date: Nov 2012
Posts: 6
 
Fuel pressure problem. 2006 ex650 with aftermarket in line fuel pump

So here's my situation.

I am on the 5 yard line with my latest build. A 2006 ex650 custom cafe racer. I put the drivetrain into a 1978 gs550 frame with lots of modifications. So I have basic esentials but no Instrument panel or original fuel pump. I built a custom fuel cell with an in line fuel pump rated at 45 psi.

My issue is this

I can turn the engine on and the bike holds an idle (a little high) but sounds great for about a minute or so, very responsive. Then the idle slowly drops and it dies like its running out of gas. I've checked fuel filter, and checked the flow to the pump. Pump is on constant on.

Could I be low on amperage causeing the pump to be too week? ( I have a small motorcycle battery and the efi fuel pump I have is for efi systems in cars. )

Is the pump too week all together since the bikes normal operation pressure is 48 psi?

Any help is appreciated.
Rat_Bastard is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome