vibration at slow speed braking - KawiForums - Kawasaki Motorcycle Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 11-04-2012, 10:52 AM Thread Starter
Jr. Member
 
Join Date: Jun 2011
Location: Hong Kong
Posts: 126
    
vibration at slow speed braking

i have a new z750, and so far ive only got around 5000km on it, but recently i notice vibration from the front brake at slow speed.

when i brake harder at low speed (10-20kmph ish) there is a major vibration sent through my bar, and i can actually hear the vibration.

everything else is fine, i can brake normally at higher speed with no problem. the pad and disc, everything is original from factory, never replaced anything.

anyone has the same problem? any idea whats wrong and what i can do?

thanks in advance.
jy7347 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 11-04-2012, 11:22 AM
Sev
The Indifference Engine
 
Sev's Avatar
 
Join Date: Sep 2007
Location: Edmonton, Alberta, Canada.
Posts: 5,995
           
Garage
Warped rotor.

Of course I'm generalizing from a single example here, but everyone does that. At least I do.


Sev is offline  
post #3 of 14 (permalink) Old 11-04-2012, 03:15 PM
Member
 
purposeinlife_1's Avatar
 
Join Date: Mar 2010
Posts: 463
           
^+111111111

04 Acura TL. Total grandma car.
06 Frontier Nismo. Meh, it's ok.
06 636. Just sits in the garage keeping everyone else company.
06 Pitster Pro GPX 125. It's planing on killing me.
07 GSXR750 Trackbike. The abuser.
purposeinlife_1 is offline  
post #4 of 14 (permalink) Old 11-04-2012, 03:41 PM
Member
 
ocjimmy's Avatar
 
Join Date: Aug 2010
Location: SoCal
Posts: 209
           
Correct! Warped Rotor. I had a 05 Z750s with the same issue. I went and replaced them with Galfer rotors and was perfect ever since.

For some reason, the stock rotors on this bike were prone to this.

Jim
ocjimmy is offline  
post #5 of 14 (permalink) Old 11-04-2012, 07:11 PM
Member
 
sprorchid's Avatar
 
Join Date: Dec 2010
Location: Bay Area, CA
Posts: 681
           
I have the opposite problem on my zx6r. I have a hum, with slight braking, but when I brake hard it's completely silent. no vibration, not felt, but there must be if it's a loud hum. some what high pitched.
sprorchid is offline  
post #6 of 14 (permalink) Old 11-05-2012, 11:07 AM Thread Starter
Jr. Member
 
Join Date: Jun 2011
Location: Hong Kong
Posts: 126
    
ahh damnit... $$$...... whats the best rotors for its price around? except for galfer, just wanna know what other options r there
jy7347 is offline  
post #7 of 14 (permalink) Old 11-05-2012, 12:51 PM
Core Member
 
goingtoscotland's Avatar
 
Join Date: Feb 2007
Location: On an intergalactic cruise, in my office
Posts: 28,589
           
Quote:
Originally Posted by jy7347 View Post
ahh damnit... $$$...... whats the best rotors for its price around? except for galfer, just wanna know what other options r there
You're going to be spending a mint for anything new, regardless of brand.

EBC, Braking, Galfer, OEM, they're all spendy.

2005 ZX-10R Street and Track Whore

goingtoscotland is offline  
post #8 of 14 (permalink) Old 11-05-2012, 12:52 PM
Member
 
zvenkruspe's Avatar
 
Join Date: Mar 2011
Location: Ottawa, Canada 2001 ZX6R
Posts: 379
           
https://www.motomummy.com/rotors/bra...ont-rotor-set/

Braking Knock off Galfer Wave rotors.

Work awesome, braked hard on them (after a gentle 200km break in period) often enough and they didn't warp (if you keep in mind not to brake hard on cold rotors).

I rode around with slightly warped rotors for almost 30 000km becuase i didn't have the spare money to replace rotors.

Just check with the other Z750 owners if your bike uses the same rims and disc diameter than a ZX6r.

If you have a private shop in your area that stocks parts from salvaged bikes, check them for some used stock rotors.
zvenkruspe is offline  
post #9 of 14 (permalink) Old 11-05-2012, 03:06 PM
Sev
The Indifference Engine
 
Sev's Avatar
 
Join Date: Sep 2007
Location: Edmonton, Alberta, Canada.
Posts: 5,995
           
Garage
Might be able to pick up a set of Alth rotors from the forums. They were going for a good price a while back.

Of course I'm generalizing from a single example here, but everyone does that. At least I do.


Sev is offline  
post #10 of 14 (permalink) Old 11-05-2012, 03:51 PM
prs
Get off of my lawn Dammit
 
prs's Avatar
 
Join Date: Jul 2005
Location: Pennsylvania, USA 2005 Kawasaki ZX 6R (636) 2005 Suzuki GSX-R 750 ----2007 Suzuki DL650 WeeStrom
Posts: 33,071
           
Quote:
Originally Posted by Sev View Post
Warped rotor.


Since he said his braking is fine at high speeds, wouldn’t a warped rotor be noticeable at higher speeds and not so noticeable at slow speeds of 10-20 kph as the OP posted? That’s always been my experience and I’m riding a bike now that has a slightly warped rotor.


And to the OP, when you brake “hard” at 10 or 20 kph you tend to stop on a dime so I don’t think you’d notice a warped rotor braking “hard” at such slow speeds. Just my $.02. What am I missing?

Sent from my transistor AM radio using my IDGAF app.
prs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome