2013 zx6r and not the 636. - Page 3 - KawiForums - Kawasaki Motorcycle Forums
LinkBack Thread Tools Display Modes
post #21 of 23 (permalink) Old 11-08-2012, 09:40 AM
Jr. Member
snx's Avatar
Join Date: Mar 2012
Posts: 63
Kawi, please call it 2013 ZX-6RR. *grins*
snx is offline  
Sponsored Links
post #22 of 23 (permalink) Old 11-08-2012, 10:09 AM
Jr. Member
2slow's Avatar
Join Date: Oct 2012
Posts: 14
Originally Posted by two6ryder View Post
Yea but you would call it the 2009-2013 model since its the same generation

Sent from my iPhone using Motorcycle.com Free App
Yes 2009-2013 zx6r. They should of called it zx6rr so that there are no confusion when ordering parts.

Last edited by 2slow; 11-08-2012 at 11:28 AM.
2slow is offline  
post #23 of 23 (permalink) Old 11-27-2012, 11:14 PM
Jr. Member
Join Date: Mar 2010
Location: Zion, IL
Posts: 20
Love the all green look. I wish we would get some solid colors over here. The black/pick your color looks awful.
thisisbenji is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome