1994 ZX9R stalls when clutch is let out - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-04-2018, 01:15 PM Thread Starter
Jr. Member
 
rcmpt's Avatar
 
Join Date: Feb 2018
Location: Frederick, MD
Posts: 2
 
1994 ZX9R stalls when clutch is let out

I just rebuilt a 1994 ZX9r and it works great, but when I let out the clutch, the bike stalls. I cleaned and lubricated the kick stand sensor, but that did not help the situation. Anybody have any answers?
Rick
rcmpt is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-04-2018, 01:51 PM
Jr. Member
 
Join Date: Jan 2018
Posts: 4
 
Quote:
Originally Posted by rcmpt View Post
I just rebuilt a 1994 ZX9r and it works great, but when I let out the clutch, the bike stalls. I cleaned and lubricated the kick stand sensor, but that did not help the situation. Anybody have any answers?
Rick
Get a multimeter and make sure the side stand switch actually works?

Sent from my SM-G928I using Tapatalk
WanaGo is offline  
post #3 of 3 (permalink) Old 02-05-2018, 08:49 PM
Jr. Member
 
jowek70's Avatar
 
Join Date: Aug 2010
Location: Madison, WI
Posts: 72
     
Bypass the switch
Itís just a loop of wire and youíre good
jowek70 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome