idle question - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-19-2008, 08:39 PM Thread Starter
Member
 
Join Date: Dec 2007
Posts: 208
 
idle question

I have a 94 kx 125 and for some reason when i was riding today it started idling really high i brought it home and cleaned the carb and backed the idle screw almost all the way out, and it still does it any ideas
00 zx6r is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-20-2008, 09:04 PM
Jr. Member
 
Jeekinz's Avatar
 
Join Date: Dec 2005
Location: New Jersey, United States.
Posts: 93
       
Sounds like an air leak somewhere. Check the intake boot and carb clamps. Cold also be a lean condition. Clean out the carb/jets, check for good fuel flow from the petcock. If it ran fine before, there's no need to ADJUST anything. There's a problem that needs to be fixed.
Jeekinz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome