New member - KawiForums - Kawasaki Motorcycle Forums
 2Likes
  • 1 Post By trexmon
  • 1 Post By caprki
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-18-2019, 09:05 PM Thread Starter
Jr. Member
 
Join Date: Jun 2019
Location: PA
Posts: 4
 
New member

2007 ZZR600 bought couple of years ago. Last week hard to start. Start up then die. Turned up idle and eventually got running. Rode about an hour then died at a stop sign. Eventually started and died 2 blocks later. Engine turns but won't start. Checked battery and bought new fuel filter. No go. Will read through posts and see if I can find help. FYI I'm 63 years old and sold my 89 Yamaha FJ1200 (bought new) and 83 Kaw 750 for the newer 600.
GR rider likes this.
trexmon is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-19-2019, 03:17 AM
Intermediate Member
 
GR rider's Avatar
 
Join Date: Oct 2013
Location: Thessaloniki, Greece
Posts: 1,962
           
Hi and welcome to the forum
GR rider is offline  
post #3 of 8 (permalink) Old 06-19-2019, 04:40 AM
bpe
Member
 
bpe's Avatar
 
Join Date: Dec 2018
Location: Atlanta,GA
Posts: 296
   
Garage

2006 EX500r
Purchased new in July 2006, 0 miles.
Miles as of January 2019 102,137 miles
bpe is offline  
 
post #4 of 8 (permalink) Old 06-19-2019, 04:58 AM
Jr. Member
 
caprki's Avatar
 
Join Date: Apr 2019
Location: Vienna, Austria, Europe
Posts: 3
 
Hello my name ist Ivan and came from Austria/Europe.
Last month i buy a 636c 2006 and iŽam very happy its realy a nice bike.
Last 10 years i had a lot of suzuki gsxr and this is my first kawasaki.
i also has read, that i can change my cluster to a 2009 cluster with the adapter from Extr400
so thats all for the first
see you, Ivan
GR rider likes this.
caprki is offline  
post #5 of 8 (permalink) Old 06-19-2019, 02:31 PM
Intermediate Member
 
GR rider's Avatar
 
Join Date: Oct 2013
Location: Thessaloniki, Greece
Posts: 1,962
           
Quote:
Originally Posted by caprki View Post
Hello my name ist Ivan and came from Austria/Europe.
Last month i buy a 636c 2006 and iŽam very happy its realy a nice bike.
Last 10 years i had a lot of suzuki gsxr and this is my first kawasaki.
i also has read, that i can change my cluster to a 2009 cluster with the adapter from Extr400
so thats all for the first
see you, Ivan
Hi Ivan and welcome to the forum

I've ridden through the weinstrasse in Stryria/southern Austria a couple of years ago and really liked it.

I also like your new bike, ride it and enjoy it!
GR rider is offline  
post #6 of 8 (permalink) Old 06-24-2019, 06:15 AM
Jr. Member
 
caprki's Avatar
 
Join Date: Apr 2019
Location: Vienna, Austria, Europe
Posts: 3
 
Thumbs up

Quote:
Originally Posted by GR rider View Post
Hi Ivan and welcome to the forum

I've ridden through the weinstrasse in Stryria/southern Austria a couple of years ago and really liked it.

I also like your new bike, ride it and enjoy it!
Thanks

Kawasaki 636c 2006
caprki is offline  
post #7 of 8 (permalink) Old 06-26-2019, 04:10 PM
Jr. Member
 
Join Date: Mar 2015
Posts: 11
 
Re: 2007 zzr-600

Quote:
Originally Posted by trexmon View Post
2007 ZZR600 bought couple of years ago. Last week hard to start. Start up then die. Turned up idle and eventually got running. Rode about an hour then died at a stop sign. Eventually started and died 2 blocks later. Engine turns but won't start. Checked battery and bought new fuel filter. No go. Will read through posts and see if I can find help. FYI I'm 63 years old and sold my 89 Yamaha FJ1200 (bought new) and 83 Kaw 750 for the newer 600.

That's a very good bike, I ride a 2005 ZZR-600 now and owned another one before that. Hope you get the running issues fixed up. It's a straight forward machine and I've never had trouble keeping it tuned. Seems like you're going to have to go thru all the basics - compression, valve timing, ignition, then carburetion to find what's up.
charger_john is offline  
post #8 of 8 (permalink) Old 06-28-2019, 01:40 PM Thread Starter
Jr. Member
 
Join Date: Jun 2019
Location: PA
Posts: 4
 
OK so it looks like the points on my fuel pump are all jacked up. Do I need specialty parts for this specific bike or can I get automotive or lawnmower stuff to work. When looking at OEM fuel pumps did not see separate parts listed. Thanks
trexmon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome