2010 ninja 250 problem with radiator, i think - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-24-2015, 08:15 PM Thread Starter
Banned
Jr. Member
 
Join Date: Mar 2012
Location: Los Angeles
Posts: 107
        
2010 ninja 250 problem with radiator, i think

got home from work, turned bike off and i heard a sizzling sound. im assuming its from the radiator since the sound was coming from the front. id rather fix this myself and not waste money at the shop. i hope just adding water or coolant will fix the problem but i cant find my manual, is there one online? is speedzonedirect legit to download the manual from?

around 3 years ago i had left the bike running idle in the garage for at least 3 hours. i had totally forgot about it. it was sizzling bad. maybe i need to put some water in there.

Last edited by bradymartin; 01-24-2015 at 08:34 PM.
bradymartin is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-27-2015, 12:09 AM Thread Starter
Banned
Jr. Member
 
Join Date: Mar 2012
Location: Los Angeles
Posts: 107
        
ok i havent ridden the bike since 2 days ago. just now i started it. after around two minutes running i noticed some heat coming from between the handle bars area and gas tank.

well, i looked at the radiator and there are 3 tubes/bars connected under the radiator, like almost retangular shape, more triangular shape. im thinking maybe they carry water and coolant from and to the radiator? i touched them and burned the hell out of my fingers. this is after two minutes at most. do i need a coolant flush at the shop? help guys

Last edited by bradymartin; 01-27-2015 at 12:12 AM.
bradymartin is offline  
post #3 of 4 (permalink) Old 01-27-2015, 12:43 AM Thread Starter
Banned
Jr. Member
 
Join Date: Mar 2012
Location: Los Angeles
Posts: 107
        
anyone?
bradymartin is offline  
 
post #4 of 4 (permalink) Old 01-27-2015, 07:11 PM
Member
 
randy218's Avatar
 
Join Date: Apr 2010
Location: Minnesnowda
Posts: 323
           
Looks like the coolant tank and radiator cap are under the right side panel. Check your tank. If there is nothing in it, check the radiator when it is cold.

https://www.kawiforums.com/ninja-250r...sh-refill.html

randy218 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome