Er6n does not rev past 4k - KawiForums - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-21-2019, 03:38 AM Thread Starter
Jr. Member
 
Join Date: May 2019
Posts: 4
 
Er6n does not rev past 4k

2012 er6n with 50k odo.

Couple of weeks ago it couldnt rev past 7k, was very busy so didnt look into it but currently it cant rev past 4/5k propperly, not on idle and not under load. When slowly build up throtllr it will sputter there, when i jank it full throttle it bwoaaps.

Started with the intank fuelfilter and pump, cleaned and checked the flow of the pump which seems good. Blew air trough all hoses and no restrictions.

Just did new sparkplugs and coils, no luck

Tried driving without oxygen sensor, no difference

No fi light

Had airfilter out and cleaned it but that shouldnt be the problem.

Any tips? When I keep throttle open for a while i see sometimes little ambers from exhaust and hear ticking in exhaust when i shut it off, seems like fuel in exhaust.
Riekus is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-21-2019, 03:45 AM Thread Starter
Jr. Member
 
Join Date: May 2019
Posts: 4
 
So when full throttle, it hesitates around 4k, then i close the throttle and it jumps in revs for a sec.

Video:
https://youtu.be/UYitMC6SGiw
Riekus is offline  
post #3 of 6 (permalink) Old 05-21-2019, 03:48 AM Thread Starter
Jr. Member
 
Join Date: May 2019
Posts: 4
 
Sorry, around 5/6k. And dont know how to edit post on mobile.
Riekus is offline  
 
post #4 of 6 (permalink) Old 05-22-2019, 03:39 PM
Jr. Member
 
Join Date: Sep 2018
Posts: 48
 
COuld it be clogged fuel injectors? Im used to carb snot Fi.
Kevinl7778 is offline  
post #5 of 6 (permalink) Old 05-22-2019, 04:02 PM
Jr. Member
 
Join Date: Sep 2018
Posts: 98
   
Have you done any work on the bike recently ?
AusEr6guy is offline  
post #6 of 6 (permalink) Old 05-22-2019, 04:11 PM
Jr. Member
 
Join Date: Sep 2018
Posts: 98
   
Watched video. I assume youíve filled it with fuel since then ?
Because it seems to improve when you close the throttle(ie less fuel required) Iím thinking you have a fuel issue.
The engine seemingly runs smoothly to a point and then hesitates. I would test fuel pressure but it could also be a metering issue ie the map sensor could be busted. It idles ok and runs smoothly to that point im guessing ignition is ok.

I am not a qualified mechanic and both of these would require some expert tools and or replacement parts to diagnose and fix. Thereís a service manual available perhaps take a look at that and see if theres any clues in there?
AusEr6guy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the KawiForums - Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
bike will not rev past 8k - like hitting the rev limiter kawigreen23 2003-2004 ZX-6R 34 05-18-2019 04:38 AM
2008 zx6r won't Rev past 10k pre Rev limiter jerredsilvers New Member Introductions 3 09-22-2015 02:14 PM
bike will not rev past 6500 rpm - like hitting the rev limiter dcoppoloPE New Member Introductions 0 05-06-2012 09:32 PM
Got a little problem...my bike will not rev past 13k rpm Jonny 2005-2006 ZX-6R 4 05-17-2009 10:40 PM
Bike will not rev passed 4k, PLEASE HELP !! dnaL0R Ninja 250R 25 06-16-2008 07:41 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome