Kawasaki Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Traded a quad for a 1995 zx11 a couple years ago. When I got it I was told all it need was a starter relay...bullshit. It now has whole new clutch from the basket out, all new dynatek ignition system carb has been rebuilt a couple times but it is finally running and I can ride it. The only issues I have left are a oil leak that I can’t quite find. It ends up trickling down the water pump...doesn’t look like it’s the shift lever I would imagine it’s something on the oil pump but looks like it leaks from the water pump. Then the other issue is it doesn’t like to maintain speed. Once you first crack open the throttle until you start accelerating it runs like shit and also runs like shit if the ram air is connected at 70mph+. With the ram air disconnected I can reach speeds of 100+ easily...I have rebuilt the carbs a couple times but still having these issues any advice is greatly appreciated. Been a two year project saving this bike from being a parts bike
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank you any advice on the ram air situation or maybe most likely culprit of the oil leak around the oil pump would be appreciated...won’t let me post in the zx11 section
 

·
Registered
Joined
·
1,824 Posts
Thank you any advice on the ram air situation or maybe most likely culprit of the oil leak around the oil pump would be appreciated...won’t let me post in the zx11 section

I'm not familiar with the ZX11's, but I noticed you were finally able to post in that section. Hopefully somebody will be able to provide you with some insight there soon.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Yea idk I thought maybe it was because I was a junior member it wouldn’t let me post in there but I saw other junior members posting so idk...maybe a time thing 🏼
 
1 - 6 of 6 Posts
Top