Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
OK guys(and girls),

I bought a 1995 zx6r as a project. Only has 8,400miles. The bike did not have any plastics, exhaust...etc.

Anyhow to make the long story short. I put the bike completely together, but it does not want to start. It CRANKS and CRANKS but I do not hear the fuel pump running(should I?), and the fuse box crackles when I press the clutch handle. I put the kickstand up, the bike is vertical when attempting to start, battery has juice and bike is in Neutral.

Soooooooo please help me where to look because I bought the bike basically naked.... put her back and now nothing! The electrical harness is not butchered or spliced anywhere.

THANKS A LOT GUYS!

PS: the guys who I bought the bike from included a non stock type upper fairing(w/headlight). Can someone tell me what year it is from so I can buy a screen? THANK YOU ONCE AGAIN!
 

·
Registered
Joined
·
155 Posts
this may sound like a dumb question but is your kill switch on? Make there arent any bad fuses, check and replace any bad ones. Also are you getting spark, take a plug out and keep it in the rubber connector thing and touch the threads to something metal like the engine and press the starter and check for spark, do it for each one. Also when you pull out the plugs see if they are wet, if you have been trying to start it and it wont start they should be wet, if not something is either blocking fuel of the fuel pump isnt working. Take the line off the carbs and aim it to a bucket and push the starter. If no fuel comes out then you fuell pump is not working. Start off simple with the switch, then fuses, and spark plugs and so on. Its usually the simple things that keep it from working.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
yea the kill switch is on the right position. the fuel pump does not come on, i touch it and nothing, not even a buzz.

im not sure which one is the fuel pump relay, but im guessing it can be shot?

i dont know, does anyone have a wiring schematic?... WITH PICS!(so i know what each part looks like)

ahhhhhhh im at a dead end here!


anyhow, anyone know what kind of front end I got?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
k guys!

I figured out there was a wire splayed by the fuel pump relay!

anyhow I soldered it back up and the pump is working! YAY!

I checked the spark and its there! thats ANOTHER PLUS!

Soooooooooo.... I need help with fuel connections! Obviously now I dont have any fuel getting to the carbs!

Anyone have a fuel system schematic?

I also need to know what a SPECIFIC part is just under the airbox, near the spark plugs. Pic is below! I need to know where one of the lines connect to!
 

·
Registered
Joined
·
155 Posts
I am not exactly sure what that is that you are holding but it looks like the airpump or valve thing on my bike minus the big black attachment yours is attached to. But if its the same part, nothing flows through there, at least not liquid, mine is not really hooked up and my bike runs great. sorry I am not more help. It might be a pcv valve? I am not quite sure though as I dont really know waht they do....
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top