Kawasaki Motorcycle Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My engine light came on the other day. I noticed that the gear position indicator was not working, just horizontal lines there. I checked the code. It was 25 - Gear position switch malfunction. My bike is still under warranty (bought in February 2018). Does anyone know what may have caused this problem?
 

·
Registered
Joined
·
14 Posts
Maybe water ingress? After I wash my bike often the o2 sensor warning will go off and after a few days will clear it self till the next wash.
 

·
Registered
Joined
·
2 Posts
Has anyone found a solution to this? I am having the same issue. Also could anyone point me towards where this gear position sensor is located?? Thx
 

·
Registered
Joined
·
2 Posts
Contacted 3 dealers and no one could lend any helpful information. Swapped my sprockets back and reset the computer by disconnecting the battery. Everything is back to normal with no issues after 1k miles. I think there is a wheel speed sensor that is causing the code when it indicates the rear wheel is spinning faster than the rpms indicate it should. A little disappointed in kawasaki for not having educated tech's in the dealerships to help with this issue.
 

·
Registered
2011 Kawasaki ER-6F
Joined
·
65 Posts
Contacted 3 dealers and no one could lend any helpful information. Swapped my sprockets back and reset the computer by disconnecting the battery. Everything is back to normal with no issues after 1k miles. I think there is a wheel speed sensor that is causing the code when it indicates the rear wheel is spinning faster than the rpms indicate it should. A little disappointed in kawasaki for not having educated tech's in the dealerships to help with this issue.
ABS models might take wheel speed into account,

This might be helpful though:

and the versys forums have the same issue:

 
1 - 7 of 7 Posts
Top