Kawasaki Motorcycle Forums banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
1,161 Posts
Discussion Starter · #1 ·
Hey guys,

I've had this installed for a while but I can't figure out for the life of me how to program it properly. It recognises N and 1st but nothing after that. When I try to program it (It's supposed to flash the gear you're in, it's then programed and you move onto the next gear) it doesn't flash at all, it just shows 1st gear and then after 2 minutes or so the bottom part of the display cycles (The manual says this is because of a slipping clutch). I've tried both on the rear stand and riding it but I can't get the gear to flash and program.

I think I might have the netural wire connected wrong (It needed light green and all I could find was an aqua and dark green wire - which is it?) but if that was the case it wouldn't recognise the shift from N to 1st, no?

This isn't the plug and play model and it's on a 2004 ZX6R. If anyone can help me out with this it would be very much appreciated. The gear indicator is second hand but it was working perfectly on the guys bike. Thanks in advance.

 

·
Registered
Joined
·
5,642 Posts
I really want one of these!
 

·
Premium Member
Joined
·
10,463 Posts
yeah i hear you on that one...
I have the same gear indicator, will take 1st and Nuetral then it will do the little circular rotatng of lights around the display...

did all they said to do with the ground wire, but have not had any luck with it..going to play with it mor when i get home in 22 days. I really like your LED rpm counter which version is it?
plug and play or a splice and dice?
 

·
Registered
Joined
·
1,161 Posts
Discussion Starter · #4 ·
It's the Digitool dice and splice version, Jdgun. I installed that without any hassles so I thought I'd go okay on this one. Heh [8)]
 

·
Premium Member
Joined
·
10,463 Posts
yeah i will figure mine out here when i gte back to the house in 3 weeks...read the directions again and do as they say...cutting and splicing, soldering is always the easy part..
 

·
Registered
Joined
·
763 Posts
just installed mine the other day.. i got the plug and play version (altho on the plug and play version they had a little wiring error that needed corrected) but after that it turned right on.

programming was easy as hell.

just press and hold it in for 10 seconds till it says L (learn) then press it 6 times (number of gears).... then put it in 1st and ride till it reads E, then put it in nuetral till it says E, then 2nd and so on. very easy.
 

·
Premium Member
Joined
·
10,463 Posts
what did you ground your wire/press it onto?
as i tried the fairing stay and a few other things to no avail.

normally i have no problems witht his shit but this time for some reason or other..
 

·
Registered
Joined
·
593 Posts
Jdgun, how did you mount the display on to the OE guage? This is also one of the upgrades I would like on my bike later on.
 

·
Registered
Joined
·
763 Posts
Originally posted by jdgun_13
what did you ground your wire/press it onto?
as i tried the fairing stay and a few other things to no avail.

normally i have no problems witht his shit but this time for some reason or other..
i have the plug and play harness so i didnt have to mess with wiring it.

but..

this might help you...






Originally posted by nevada
i want one of these. how much and whats the site?? link??

well i want one..ofcourse if the bugs get worked out.
those bastards and their gixxers..ALWAYS knowing what gear they're in
i have one for sale VERY cheap right now if your intrested...

http://www.KawiForums.com/forum/topic.asp?TOPIC_ID=64705
 

·
Premium Member
Joined
·
10,463 Posts
billas double R

Yeah that is on there with some of that heavy duty car velcroo stuff..it is in a aluminum housing i bought from some site i have no clue where anymore...But got 2 housings for $9.00 billet aluminum non the less one silver for the ZX, 1 red for the RC51...

I will just order a Blue plug and play for the RC51 to match my blue gauges instrument panel...

Need to do my ZX's but i dont ride at night or anything though..oh well
 

·
Registered
Joined
·
5,642 Posts
Originally posted by jdgun_13
billas double R

Yeah that is on there with some of that heavy duty car velcroo stuff..it is in a aluminum housing i bought from some site i have no clue where anymore...But got 2 housings for $9.00 billet aluminum non the less one silver for the ZX, 1 red for the RC51...

I will just order a Blue plug and play for the RC51 to match my blue gauges instrument panel...

Need to do my ZX's but i dont ride at night or anything though..oh well
if you find out where it was that you got that from, please update me.. I'd really like to get one of those aluminum housing pieces.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top