Kawasaki Motorcycle Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
3,020 Posts
Discussion Starter #1
What make a bike start running rough and hesitate when it heats up and the hotter it gets the worse it hesitates. Thinking injectors, its not plugs it still did it after i changed the plugs.
 

·
Registered
Joined
·
3,020 Posts
Discussion Starter #3
well its at 15k so i need to do valve adjustment and TB sync but would heat be an issue with either of those
exhaust and filter only mods but had them for a while, i know a PC would fix the problem but dont really have the xtra money now and i think it would just hide the real problem anyway
 

·
Registered
Joined
·
879 Posts
i'm fairly certain a PC wouldn't fix that, especially if its heat related.... do the maintenance as soon as possible. if that doesn't help, i got nothin' for ya..
 

·
Registered
Joined
·
170 Posts
Same thing happend to me...when the bike got hot its would almost sound like it was a spark plug missing or foulded, but not constant. It would come and go. I had my vavles adjusted, tb's synchroed(spelling) and it runs like a champ, hot or cold. My mechanic said that when the valves seat you don't have the clearance needed when the motor gets hot. He said that this could cause the motor to sound like it was an electrical problem, meaning spark plug or coil. Don't know if this makes any sense, but I can tell ya that's all we did and it has not skipped a beat since.
 

·
Registered
Joined
·
7 Posts
The same thing is happening to my bike right now.... only problem is it gets worse and stalls, good thing i saw this thread and maybe this will help me with my problems too. thanks a lot!!!
 

·
Registered
Joined
·
3,020 Posts
Discussion Starter #10
I need to rant a little cause im in a bad mood but heres the update. I took it to the shop to get the valves adjusted and tb's synched, and the mechanic says to me that it might be something else more simple than that and instead of spending the money to get the valves done and tb's synched hes gonna run a compression test on it for me to see if the valves are off. He went on to say that modern sportbikes rarely need valves adjusted and the guy at the counter said he never synched the tb's on a sportbike in his life and that likely was not an issue. I've dealt with these guys a lot before and they're nice people, usually very helpful and not real expensive (It's the shop ricky gadsen owns btw so you would figure they know what theyre doin, they work on all his bikes and hes usually in the back workin on bikes too). So the guy says they're backed up for a week or two. Never been an issue before with them, they've always taken care of my bike the same day. Anyway they said something happened with another bike and as of today they haven't looked at it and won't get to it until sometime next week. I dropped it off last wednsday and theyre closed sunday and monday, so this is gonna wind up bein at least 2 weeks before they look at it. All this isn't really a problem except for the fact that my car just got impounded for parking tickets and i wont likely have it back if at all for a few days and even then at the cost of $500-$1000 which i dont have. To top it off the weather has been and is supposed to continue to be pretty warm. So i'm just frustrated now that i have no mode of transportation and i'm stuck waitin on my bike and i dunno what theyre gonna do with it. I even thought about just gettin the bike back off of them so i had a way to get around but that would just set me back further cause i'm eventually gonna need to do something about it.
 

·
Registered
Joined
·
133 Posts
the stealership lied to you. bikes DO need throttle bodies sync'd or you get fookin awful stutters and hesitation when you gas it. its not the valves being loose - they get noisy but they're not gonna cause bad hesitation. if anything was gonna go wrong on loose valves it would be that you floated one. go to a different shop (one that knows how to sync your throttle bodies) have them sync your TB's and change your spark plugs, put your bike in diagnostic mode 2 see if your FI system is good, and your bike will be back to haulin ass in no time!!
 

·
Registered
Joined
·
1 Posts
I need to rant a little cause im in a bad mood but heres the update. I took it to the shop to get the valves adjusted and tb's synched, and the mechanic says to me that it might be something else more simple than that and instead of spending the money to get the valves done and tb's synched hes gonna run a compression test on it for me to see if the valves are off. He went on to say that modern sportbikes rarely need valves adjusted and the guy at the counter said he never synched the tb's on a sportbike in his life and that likely was not an issue. I've dealt with these guys a lot before and they're nice people, usually very helpful and not real expensive (It's the shop ricky gadsen owns btw so you would figure they know what theyre doin, they work on all his bikes and hes usually in the back workin on bikes too). So the guy says they're backed up for a week or two. Never been an issue before with them, they've always taken care of my bike the same day. Anyway they said something happened with another bike and as of today they haven't looked at it and won't get to it until sometime next week. I dropped it off last wednsday and theyre closed sunday and monday, so this is gonna wind up bein at least 2 weeks before they look at it. All this isn't really a problem except for the fact that my car just got impounded for parking tickets and i wont likely have it back if at all for a few days and even then at the cost of $500-$1000 which i dont have. To top it off the weather has been and is supposed to continue to be pretty warm. So i'm just frustrated now that i have no mode of transportation and i'm stuck waitin on my bike and i dunno what theyre gonna do with it. I even thought about just gettin the bike back off of them so i had a way to get around but that would just set me back further cause i'm eventually gonna need to do something about it.
Any update on what was wrong with your bike
 

·
Registered
Joined
·
2 Posts
I had a similar problem on my 03 636.
Started running hot and began to misfire and hesitate when riding.
Rust sediment had blocked the fuel filter and was starving the engine of fuel. Thus the hotter running temps and the rough running.
Previous covered on here to clean filter

Worth a try. Even a YouTube video that I found useful when doing mine and someone covered it on this forum as well.

Only other time I had a similar issue hesitation misfire was a defective PC3. I unplugged it from the loom and binned it. The bike has never misfired since.
 
1 - 15 of 15 Posts
Top