Kawasaki Motorcycle Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
110 Posts
Discussion Starter · #1 ·
So I havent been on the forum in a little while, I sold my 03 ZX6RR and got a couple CBR's. I still have an 03 636 stunter... To the point... Today I just purchased an 07 ZX6R with 2,000 miles, yes almost new. Has been laid down but not too badly, just cosmetic. I am not too familiar with this bike and it seems a common problem that the fuel pumps are clogged/dirty. The bike has been sitting so I ran old gas out and put new gas in and still running choppy. It is almost dangerous how much of a slow starter this bike is. You can pin the throttle in first and second and its almost nothing at all until over 6 grand.. It just bogs down, I can twist it all the way open and it hiccups bad. I got rid of my F4i because it didnt have enough balls and this thing is terrible, must be something wrong or clogged. Should I just assume its the fuel pump? Then troubleshoot from there? Thanks guys.
 

· Registered
Joined
·
17,476 Posts
just to cover all bases, pull the tank the check the airbox and filter. you said the bike was sitting, and airboxes make great mice nests.

while the tank is pulled, pull the pump and see if its clogged. do your best to clean it as best as you can, unfortunately the 07/08 pump isnt easily rebuildable so a used option is your best bet. if the pump is good check the injectors and spark plugs.
 

· Registered
Joined
·
110 Posts
Discussion Starter · #4 ·
just to cover all bases, pull the tank the check the airbox and filter. you said the bike was sitting, and airboxes make great mice nests.

while the tank is pulled, pull the pump and see if its clogged. do your best to clean it as best as you can, unfortunately the 07/08 pump isnt easily rebuildable so a used option is your best bet. if the pump is good check the injectors and spark plugs.
Thanks hedzor. yah tomorrow Ill take the tank off and take a good look.. Took it out today... The bike is a beast from 6-8 grand on.. 5th gear 142mph (what the speedo read) at 14 grand. First day on it really and love it besides all the low flat spots and hesitation.. If it is not the pump/filter/ air... I may just try gearing and assume its how they are factory? $3500 was a steal for it. I expect some crap!
 

· Veteran Lowsider
Joined
·
20,823 Posts
Thanks hedzor. yah tomorrow Ill take the tank off and take a good look.. Took it out today... The bike is a beast from 6-8 grand on.. 5th gear 142mph (what the speedo read) at 14 grand. First day on it really and love it besides all the low flat spots and hesitation.. If it is not the pump/filter/ air... I may just try gearing and assume its how they are factory? $3500 was a steal for it. I expect some crap!
i think thats just how this bikes are, my full exhaust made my low end alot worse but my top end awesome

8K+ is like a light switch
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top