Kawasaki Motorcycle Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hello everyone new guy here with an issue i got a 03 zx6r with yoshi exhaust, power commander, 14/41 sprockets. my issue is i cant keep up with cars on the road i feel like a grandma riding, at every gear i gotta shift at 7000 cause i soon as i get to 7500 i loose throttle drops to like 5500 and i gain throttle again until 7500 any suggestions?
 

·
Registered
Joined
·
59 Posts
Is the engine not revving above 7500 no matter how far you open the throttle?
You could try getting your throttle position sensor checked out with a multimeter...
Hope this helps.


Sent from my iPhone using Motorcycle.com App
 

·
Registered
Joined
·
51 Posts
Have you checked the fuel lines make sure there not kinked or twisted.

Sent from my HTC One X using Motorcycle.com Free App
 

·
Registered
Joined
·
41 Posts
there are many things that can cause the issue but we know its more than likely to do with the fuel to air ratio due th the fact that you said it accelerates fine to around 7500 rpm then cuts and then back so first id check the air supply, vacumes to and from air box air box gasket vacume from throttle bodies to pair valve air filter and then ide check the barometric pressure sensors then the fuel pump the pump can be weak supply enough fuel to run the bike to a certain extent the bike can use more fuel than the pump can supply after that
 

·
Registered
Joined
·
7 Posts
Had same issue with my 03 636 and I replaced the fuel pump with a 13 636 pump and it pulls hard now just a suggestion
 
1 - 12 of 12 Posts
Top