Kawasaki Motorcycle Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter · #1 ·
I have question about how to connect the tailight turn-signal wires to
the stock connector. Has anyone just cut the connector off? Or what kind of
connection did you guys use who have the Clear Alternatives?
 

·
Registered
Joined
·
88 Posts
I just tapped into the wiring before the oem plug so it could be put back stock later if needed. Just strip the wire bike and wrap the wire through or solder which ever you prefer. Cutting the wires could be done too if you like. I didn't even need the resistors for mine and my flash works perfectly.
 

·
Registered
Joined
·
744 Posts
I just cut the stock blinker connectors off and wired them to the CA light so that I could still plug and unplug them as needed.
what he said
 

·
Registered
Joined
·
184 Posts
The previous owner who had the bike idiotically cut off the stock harness while installing the exhaust.. doesn't matter though, as long as you still have a wire it'll still pick up a signal.
 

·
Registered
Joined
·
274 Posts
Discussion Starter · #6 ·
I can't get my left integrated signal to blink while signaling left. The only time it will blink is if its connected to the postive while signaling right. Freaking frusterating! Are both wires supposed to be connected to the postive wire? What about the gray wire?
 

·
Registered
Joined
·
297 Posts
I don't remember the exact colors, but the yellow wire on either side connects to the positive wire for the blinker on their respective side. You only need to worry about one wire because the whole circuit grounds inside the taillight.
 

·
Registered
Joined
·
518 Posts
has anyone had the problem of their CA tailight craping out after a few years? mines like 3 years old and doesint want to stay lit anymore, it will flicker if i tap it, i wanna get this fixed before i get rear ended.
 

·
Labia Grappler
Joined
·
3,744 Posts
those who have the CA taillight how did you hid the wires for the license plate light?
I tucked mine into the little bendy brackets on rear most section of the subframe.

has anyone had the problem of their CA tailight craping out after a few years? mines like 3 years old and doesint want to stay lit anymore, it will flicker if i tap it, i wanna get this fixed before i get rear ended.
Mine is about 18 months old ... and just recently, I now have one row of LED's that sometimes works and sometimes doesn't.
 

·
Registered
Joined
·
768 Posts
has anyone had the problem of their CA tailight craping out after a few years? mines like 3 years old and doesint want to stay lit anymore, it will flicker if i tap it, i wanna get this fixed before i get rear ended.
I had a chance to open up one of their tail lights just to take a peek inside and I must say the quality is definitely lacking. I don't have the specs on the LEDs they use but there's a good chance they're getting overdriven since so many people complain about them partially going out.

Besides, the ones I've seen have such a narrow viewing angle and low output I think I'd be afraid to ride with one of their tails in the daylight regardless.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top