Kawasaki Motorcycle Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
when i let off throttle it takes forever for the speed to come down above 3k rpm,when it hits below 3k rpm then it will finally drop to 1000.carbs have been cleaned cables are free.is this a problem with the coast enricher? when the engine is cold seems not to happen,but sometimes when warm it doesnt happen.big pain in the ass going into corners not knowing if youre going to get engine braking.
 

·
Registered
Joined
·
3,820 Posts
Sounds like you have an air leak. Recheck the seating of the carbs at the throttle body to make sure they are in the intake boots all the way. Could also be a missing vacuum cap or really out of whack pilot jet adjustment.
 

·
Registered
Joined
·
3,820 Posts
Can you expound on your pilot jet adjustment?
Well, you adjust the pilot jet circuit through the air screw. I have no idea where there are on a 250 though, haven't looked at the carb on one of those in almost 20 years. Google search it, tons of stuff comes up.

I would check the carb boots first though, did the bike run fine before you took the carbs off ? If it did then I doubt its the pilot jet, unless you messed with them during cleaning.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Found out id i quickly turn choke on and off it decelerates to 1000rpms.,does that lead anybody to an answer?
 

·
Registered
Joined
·
3,820 Posts
Found out id i quickly turn choke on and off it decelerates to 1000rpms.,does that lead anybody to an answer?
If turning the choke on helps it means your running too lean. Air leak can cause this or it might be needing adjustment of the pilot circuit.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
deacceleration

no when i put the choke on and off as fast as i can,then the idle drops to 1000 like it should with clutch pulled in
 
1 - 8 of 8 Posts
Top