Kawasaki Motorcycle Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
08 Kawasaki Ninja250R. Tried to take a ride today, found out my underbody lights have been somehow turned on and left on, probably since 2pm yesterday, and now my engine wont turn. All lights work, horn is soft but is going out. Would it really be that my batt is dead? or could it be a blown fuse? or could the batt being left in discharge so long have gotten sulfated?
 

·
Registered
Joined
·
131 Posts
I don't know about the battery being sulfated but it does seem like its very very low on juice. Do you have a battery charger/tender to maybe hook it up to? I think cranking it might drain your battery more unless it catches. Hope this helps - someone more knowledgeable about ninjas should be coming in soon enough.

Good luck and keep us posted.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I don't even have the tools to get the fuse box or battery. My neighbor down the street has a charger and tools but I don't want to push it down there until I have a more clear idea as to what's wrong and what needs to be done.
 

·
Premium Member
Joined
·
41,542 Posts
I don't even have the tools to get the fuse box or battery. My neighbor down the street has a charger and tools but I don't want to push it down there until I have a more clear idea as to what's wrong and what needs to be done.
Did your bike not come with a basic tool kit?
 

·
Registered
Joined
·
77 Posts
seems obvious, you left your lights on (like in a car) and now the bike wont start, battery is dead. You can have a buddy push start you, i had to do it on my gixxer when my friend left my lights on overnight.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
simple jumpstart was all it needed. thanks for the help =]
 
1 - 8 of 8 Posts
Top