Kawasaki Motorcycle Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
660 Posts
Discussion Starter #1
Any ideas on what to check and how? Few weeks ago fi light was intermitantly coming on and off, bike ran fine, been off since now today went on a 20 mile ride, FI light came on steady and is still on. Only thing diferant is I changed my yosh RS5 slip on to a Leo Vince evo11 also slip on. Any ideas would be appreciated.. Thanks
 

·
Registered
Joined
·
660 Posts
Discussion Starter #4
Duh, no! I will pull the code tomorrow n I betcha it'll tell me it's a servo issue.. Weird though, I had a yosh Rs5 on it for years n never had that issue. Must be the leo.. Thanks zx6rrnewb, I totally missed that, dunno y I didn't think of it , prob cause it would be the simplest thing haha...
 

·
Registered
Joined
·
38 Posts
I have a YOSHI on mine and I don't think I have the servo eliminator.. I think my FI light has only been on once or twice in the past.. usually sorts itself out with a restart.
 

·
Registered
Joined
·
3,609 Posts
Duh, no! I will pull the code tomorrow n I betcha it'll tell me it's a servo issue.. Weird though, I had a yosh Rs5 on it for years n never had that issue. Must be the leo.. Thanks zx6rrnewb, I totally missed that, dunno y I didn't think of it , prob cause it would be the simplest thing haha...

I had a similar issue. I had had an FI servo bracket on the bike for years and no FI light. One random day it started blinking on and off but the bike ran and idled fine. I pulled the FI light code for and it was something to do with the servo so I bought a servo buddy servo eliminator and it fixed everything after I put it in.


Sent from Motorcycle.com App
 

·
Registered
Joined
·
20 Posts
Woah, slow down folks. The F1 light comes on when the O2 sensor on the stock pipes isn't picking up the signal. Now that your stock pipe has been replaced the F1 light will always be on.

Mine has been on for 3 years since I put in my Jardine pipe. You'll learn to ignore it!
 

·
Registered
Joined
·
3,609 Posts
Woah, slow down folks. The F1 light comes on when the O2 sensor on the stock pipes isn't picking up the signal. Now that your stock pipe has been replaced the F1 light will always be on.

Mine has been on for 3 years since I put in my Jardine pipe. You'll learn to ignore it!
1)there is no 02 sensor on the 05-06 USDM ZX6R.
2)it's an FI light for Fault Indicator, not F1(for some reason the kawi owner's manual says it's for fuel injection but most every other manufacturer i've seen refers to it as Fault Indicator in theirs.)
3)the FI light comes on when you buy an aftermarket exhaust because removed the cables that open and close the valve right before the factory muffler, and you removed the valve itself. Now the servo that controls that valve spins freely under rider's seat and the ECU thinks there is an issue with the bike, triggering an FI light. Most aftermarket pipes come with a bracket you put on the servo and it limits how many degrees it can spin and it tricks the bike into thinking everything is in order. You can make one with like $4 worth of stuff from home depot.
4)You should fix your FI light. Unless you regularly pull the fault codes, if there is an actual issue with the bike, you won't know because your light's always on.

I had an issue similar to the OP's and removing the servo and putting in a servo buddy remedied the issue.
 
1 - 9 of 9 Posts
Top