Kawasaki Motorcycle Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey guys, I just bought my first street bike the other day, and it happened to be a 97 zx7r.
first off, after a couple days of owning the bike, I started riding and after about 15 min of riding, I came back home and turned it off. It instantly started smoking, so I find where its coming from and its coming from the round thing beside the oil filter (that was loose) or the oil filter.

so I stopped riding and changed the oil and filter and the bike was 2 quarts low. I cleaned up the bike and got all the oil off from where it had been leaking thinking it was the oil filter.

but today as I get off work and get to WalMart, the bike is smoking again and there are droplets of something (oil/water can't tell) on the round thing beside the oil filter. Can someone tell me what could be going on?

and also, my fan is spliced to turn on when the key is turned, and there are 2 connectors on each side of rad that aren't plugged in, what would they go to???

I'm new to the street bikes, I've raced motocross but I don't know a lot about the wiring of a street bike. Info would help a lot!!!
 

·
The Indifference Engine
Joined
·
6,150 Posts
The extra wires are probablythe temp sensor. Turning on with the key isn't great. But better than nothing.

Not sure about the leak. Clean it up and dust a little flour on the area. That'll let you back track the source and replace the leaking seal.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
thanks Sev! I'll deff try that. I tore down the bike last week and it was dirty. Flushed rad, it was a rust brow, cleaned air filter, new plugs, etc.. I can tell the bike is running a lot better. But now its leaking coolant, from behind the header, there is a hose going into what looks to be a square with bolts around each corner. Idk what that is, but is there a seal around it? That may need replaced? I'm thinking since its cleaned out, its leaking in places that used to be gummed up. Thanks again for the advice above.
 

·
That Fighter Guy
Joined
·
15,175 Posts
When you're trying to get help with these kinds of issues, it helps a lot to post pictures. "The round thing" is about as vague as you can get. Is it the stator cover? We don't know. Make sense? I think Sev is right that you have a leaking gasket on one of the engine covers. You can get replacements online or use black RTV. I believe it's called Ultra Black or something like that. It's gasket maker and works perfectly. An OEM gasket is less messy and easier to install though. To each his own really.

For your radiator it sounds like your nozzle or hose has a leak. Tighten the hose clamp and see if that helps. If not, I think the nozzle has an O-ring...I'm not 100% sure on that one, I've never had a leak there, so I've not taken that apart before.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
ill be posting pics asap! But for now I'm using my cell phone and it won't let me post them. Thanks for the tips. Like I said, I'm.new to the street bike world.

Has anyone on here ever tried the tail swap for the zx7? I've seen pics of r1 tails but I'm not 100 percent on what's the easiest tail to use or what method. And another thing, the guages are ugly, I hate the needles, where would be a good place to find a digital one for a good price?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7

Attachments

1 - 7 of 7 Posts
Top