Kawasaki Motorcycle Forums banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
1,690 Posts
If the right side wasn;t working...why did you check the left?
 

·
Registered
Joined
·
370 Posts
im not sure these two guys gave you an actual answer...
take off your seat cowl...and then take the "black bucket out", the one where your tool lie in, under there is the wire that goes to the blinkers, check the wiring maybe something got disconnected...
 

·
Registered
Joined
·
748 Posts
ok...tryin to decipher this and see if i understand... when you select *right* you get no blinkers nor does your indicator flash for the right side?!? but when you select *left* everything works as advertised on the left?!? sounds to me like a switch issue...possibly the wire connection at the left handlebar switch unit. on my kawis, the turn signal relay/flasher is *before* the handlebar switch, thus you would have the same issue on both left AND right side.
also possiblity of a short between the switch and right signal/indicator lights. or as moloko said, both bulbs burned out, but i would think that your indicator would still flash, albeit at a faster rate.
 

·
Registered
Joined
·
93 Posts
check your blinker fluid, it may just be a little low on the right side...

the indicator will still flash even if you completely remove your blinkers, get a voltage tester and check your voltage at the bulbs, if you have voltage there then it is the bulb, if you don't then the problem lays between the swich and the bulb, if all that checks out then it is the relay....

i had the same problem on my bike, it turned out to be a bad swich, but i would start with at the bulb and work your way back from there...
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top