Kawasaki Motorcycle Forums banner
161 - 180 of 212 Posts

·
Registered
Joined
·
28,313 Posts
Discussion Starter · #161 ·
its probably somethin like a rev limiter or timing deal if there is a difference at all. look in the manual and compare timing numbers. i know the FRENCH bikes are a bit different.. the cam timing and duration are different, and theres some other changes.. but i think the canada and us ones are the same.
 

·
Registered
Joined
·
3,020 Posts
My buddy has a 95 zx7r. He's had it about a month, and never had a problem starting it. Today sitting in traffic it died and wouldn't start back up. We had to push start it to get him going again. Then it died again and we had to push start it again. It was fine after that and when we got out of the traffic. So I guess he's got the same hot starting problem, you were talking about before. Any definite or probable fix yet?
 

·
Registered
Joined
·
7 Posts
I have a P5 model (year 2000) ZX-7R.

My fan did melt, but I believe it was attributed to the Akrapovic full system upgrade. The muzzy fan aluminum upgrade did the trick.

I also noticed that the bike won't fire right up after shutting it off and when it is hot. I noticed that you'll have to play with the choke lever.

A trick that my mechanic told me about the switch - sometimes I notice that when I press the start button, it will not start. He told me to spray some WD40 into the red kill switch button contacts.

I tried push starting this sucker, it won't work - even in first gear, with the clutch lever pulled in, it is locked into place.
 

·
Registered
Joined
·
28,313 Posts
Discussion Starter · #167 ·
My buddy has a 95 zx7r. He's had it about a month, and never had a problem starting it. Today sitting in traffic it died and wouldn't start back up. We had to push start it to get him going again. Then it died again and we had to push start it again. It was fine after that and when we got out of the traffic. So I guess he's got the same hot starting problem, you were talking about before. Any definite or probable fix yet?
I have a P5 model (year 2000) ZX-7R.

My fan did melt, but I believe it was attributed to the Akrapovic full system upgrade. The muzzy fan aluminum upgrade did the trick.

I also noticed that the bike won't fire right up after shutting it off and when it is hot. I noticed that you'll have to play with the choke lever.

A trick that my mechanic told me about the switch - sometimes I notice that when I press the start button, it will not start. He told me to spray some WD40 into the red kill switch button contacts.

I tried push starting this sucker, it won't work - even in first gear, with the clutch lever pulled in, it is locked into place.

yup.. can't start it if it won't get fuel! that wd 40 trick makes no fucking sense. it's not an electrical issue AT ALL.
it's vapor lock 100%

wrap the fuel lines up with whatever you can find that'll reflect heat. this helps. when stopped, pop the bike in gear and hold the starter button down and rock the bike back side to side violently. lol it moves the bubbles and so far has been sucessful for me. i rock it til i hear the pump load up with fuel and stop. usually it'll start then.
after this job is done and i'm back home i will probably buy a megasquirt. stay tuned on that. i will offer kits. probably around $900 or less when it's all said and done. pre-programmed and ready to install with all the shit you need. thats what i'm aiming for anyway.
 

·
Registered
Joined
·
3 Posts
did you figure out how to fix the junction box or is better to replace? i just picked up a 94 and it doesnt want to turn over. i did get it to turn over by tapping on the junction box but that only lasted for so long. i am also not gettin any spark?
 

·
Registered
Joined
·
28,313 Posts
Discussion Starter · #169 ·
the junction box isn't the problem. its the solenoid.

as far as spark, run all the resistance checks. could be the typical gray wire syndrome, could be a component failure such as a trigger coil or fuel pump relay.
its a small problem with a broad range of causes.
 

·
Registered
Joined
·
31 Posts
I hate hot weather!!!!! The 7 hates it more! lol. The 7r hates to run out of gas too!!!

Like hendrix said... priming the fuel system usually helps the hot start. I actually have a single switch wired in to the little green wire for the starter. If I'm having a bad time starting after running out of gas, etc. I turn it off and listen til the fuel pump stops and then turn the starter back on. vroom.

I love/hate this bike all day every day.

After getting my full kerker installed on the bike has been starting a lot better as well. I still need to get it properly tuned for it though.
 

·
Registered
Joined
·
2 Posts
Wow! What a lot of excellent info for the ZX7R! Thanks to all and especially whitehendrix.
My problem is my headlight relay. I'm fairly certain it has died. With use of the wiring diagram, I have jumped a wire between the brown and blue/yellow wires at the junction box to give me my headlights. Can some one help me verify "test" that the relay is bad and possibly replace? The solder contacts on the PCB seem fine. 2003 P model US.
Thanks.

P.S. I too have a troublesome starter relay. Thanks for pointing it out. For some reason pulling in my clutch lever and releasing it works.
 

·
Registered
Joined
·
28,313 Posts
Discussion Starter · #175 ·
this thread at this point has almost 30,000 views. from now on, everyone owe me a $1.00 for every view made.

and i'll be sure to add some more stuff.
 

·
Registered
Joined
·
3 Posts
thanks for the info, wonder if you could help diagnose a problem. Had my 2001 7 garaged for 3weeks for holidays and when I tried to start it this morning it was taking a little while to kick(understandable) and didn't want to burn out starter motor, so turned off the key, turned it back on, pressed the button, starter motor kicked in...then I lost all power. Battery is reasonably new and didn't wind down like flat, the bike just went dead, no dash lights or anything. Any Ideas? Thanks
 

·
Registered
Joined
·
53 Posts
thanks for the info, wonder if you could help diagnose a problem. Had my 2001 7 garaged for 3weeks for holidays and when I tried to start it this morning it was taking a little while to kick(understandable) and didn't want to burn out starter motor, so turned off the key, turned it back on, pressed the button, starter motor kicked in...then I lost all power. Battery is reasonably new and didn't wind down like flat, the bike just went dead, no dash lights or anything. Any Ideas? Thanks
Check the 30A fuse on the starter relay. Follow the wire from the red side of the batter, the fuse is in there.
 

·
Registered
Joined
·
53 Posts
161 - 180 of 212 Posts
Top