Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
1,765 Posts
Discussion Starter #1
man, i was rideing about a mile away from home, all of a sudden i smell anti-freeze, the bike started getting hot and all of a sudden my bike is sitting in a puddle of anti-freeze at the stop light. WTF, i took all front fairings apart and didnt find a hole in the radiator.

all i could see is fluid steam coming off the top of the radiator, but no hole, or squirting probably because the bike didnt have any fluid left.

PLEASE HELP ME.
 

·
Registered
Joined
·
2,265 Posts
Sounds like it overheated. Have you done any work on the bike recently? Was the radiator cap in place and all the way on? Also check all the coolant hoses for holes, make sure the reserve tank is intact and make sure the drain plugs are in place on the engine.
 

·
Registered
Joined
·
394 Posts
Dealership?
 

·
Registered
Joined
·
1,765 Posts
Discussion Starter #4
YEAH, i am going to take it to the dealership tomorrow, but my worry is that they are going to blame me for the alarm, or the small dent on the side of the radiator or because the hid ballasts or alarm. :(

i wonder what they are going to say?
 

·
Registered
Joined
·
1,537 Posts
Might be a loose hose clamp. Had one on mine as many many others have as well. Funny it was fine, then I pull it outof the garage to show it off...start it up and its puddling antifreeze under the bike. I had them come and pick it up....dealership too far away to risk riding it to them..
 

·
Registered
Joined
·
1,537 Posts
Yep....I just layed down $8000 on a new bike and only had like 300 miles on it. I'll be damned if i'm gonna risk damaging it by trying to ride it 25 miles to the dealership....
 

·
Registered
Joined
·
1,765 Posts
Discussion Starter #8
I paid $550 for warranty on any motor damage that may happen to the motor within 100k miles i believe, but either way, i took my bike to the dealer today, I wont know what happend to the bike for another couple days, sucks because i want to ride it to a huge car show in reno "hot august nights" [B)]

hopefully they will have it fixed before august 9th.
 

·
Registered
Joined
·
394 Posts
My coolant pipe clamps was also a bit loose. I tightened the ones I could find. The one on the left side of the bike going into the radiator had some stuff seeping out there. Looked like corosion. Cleaned it up, tightened it and its been fine ever since. Maybe you should strip the fearings and go through all your hoses.
 

·
Registered
Joined
·
1,367 Posts
Ralph definetly check your clamps, hoses, and radiator cap. All my clamps were loose when I bought the bike and caused the hoses to slowly leak coolant. There are a couple clamps that can only be accessed with the tank removed and those were the spots where my bike was leaking from the most. I just did my 14k service (air filter, plugs, etc.) and found that the clamps had worked themselves loose again.
 

·
Registered
Joined
·
1,765 Posts
Discussion Starter #11
I already took the bike to the dealer, but today i called and they said that they wont be able to look at the bike for a week to a week and a half. that sucks, man, i kinda want to get my bike and try the clamps.

is anyone willing to help me out?
 

·
Registered
Joined
·
2,265 Posts
I woul go pick up the bike if they can't even look at it for that long. They will probably chanrge an arm and leg for the work too. Go pick it up and just start going over it yourself and learn something about the bike while you are at it.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top