Kawasaki Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am currently building an 82 Yamaha zx750. I didn't like the stock front end and I came across a complete 85 kawi zx600a front for pretty cheap so I bought it. The bike is turning into a vtwin/cafe/tracker build and its almost done.

I can throw up some pictures if anyone wants.

My problem comes from trying to use a universal speedo from DCC that isn't so universal. Its a pretty gauge and I want to stick with it, but the stock 85 zx600 drive cable won't fit in the hole. I've searched the Internets and found nothing helpful thus far. The second step is to ask the pros.

Short of shaving up the cable end, how do I make the cable fit? Has anyone experienced this? Does anyone have advice? Any and all help would be greatly appreciated. Im at the end of my rope with this yami, nothing has been easy with it. Help!

Russell
 

·
The Indifference Engine
Joined
·
6,150 Posts
If you get a new gauge. The problem you will have is that a mechanical pickup is hear driven, so even if you make it fit somehow there is a very good chance the drive and gauge are two different ratios and it'll either display the wrong speed or just wreck the gear teeth.

Might want to find another gauge, which is why I suggested a magnetic pickup.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
The ratio for the speedo is a 2240:60 which I understand to be very similar to the gear drive ratio. Are there any adaptors you would recommend? Or gauges for that matter too.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
This thread can be closed, I solved the issue, turns out I'm an idiot. I can rebuild engines but I apparently can't put a speedo cable in the right way......

...

...

Ashamed...
 
1 - 6 of 6 Posts
Top