Kawasaki Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
So I have a 2017 ZX10-RR after some riding yesterday, when I got home the bike is stuck at idling at 3k rpm. Not really sure what it could or if it’s just a sticky throttle cable. Asking for some DIY advise. All any will be much appreciated. Thanks in advance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
So I have a 2017 ZX10-RR after some riding yesterday, when I got home the bike is stuck at idling at 3k rpm. Not really sure what it could or if it’s just a sticky throttle cable. Asking for some DIY advise. All any will be much appreciated. Thanks in advance.
Need help can someone please help me out? Thank you
 

·
Registered
Joined
·
2,561 Posts
Need help can someone please help me out? Thank you
Hi there, I don't think that your bike has a throttle cable, if I am not mistaken it has advanced electronics which require ride by wire throttle.

Have you tried adjusting the idle to see if the revs are dropping at all?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hi there, I don't think that your bike has a throttle cable, if I am not mistaken it has advanced electronics which require ride by wire throttle.

Have you tried adjusting the idle to see if the revs are dropping at all?
Yes I have tried to adjust the throttle cables with no go. I did some research on it and there's a throttle control sensor setting that's related to the ECU which I'm guessing will be related to the mapping.
 

·
Registered
Joined
·
267 Posts
The only Throttle Sensors I am aware of are the T.P.S & Sub T.P.S Sensors that are Factory set.
They are adjustable but this is normally only required when you have to replace one because the securing screws have a Locking compound on them similar to Loctite which prevents them from moving on their own.
Unlikely one has come loose and if one had gone faulty it would throw a Fi Code on the Meter.
I had a customers Bike years ago that had the opening Throttle cable jump out of the Throttle body locating slot because his throttle had way to much slack in it and that caused a high Idle speed so might be worth checking yours are correctly located at the Grip and Throttle Body.

If you start the Bike now from cold and let it sit there does it still Idle at 3k when up to temp?
 
1 - 5 of 5 Posts
Top