Kawasaki Motorcycle Forums banner
1 - 20 of 27 Posts

·
Registered
Joined
·
1,069 Posts
Discussion Starter · #1 ·
Hey i was just curious if anyone else has problems with there integrated tail lights always working their way loose. I cant seem to keep it stuck to the top of the the rear fender whatever i try. I can tighten it down real tight but it seems to always work its way and it just starts to sag. Does anyone have a way to keeping the light in place instead of always starting to sag???
 

·
Labia Grappler
Joined
·
3,744 Posts
Hey i was just curious if anyone else has problems with there integrated tail lights always working their way loose. I cant seem to keep it stuck to the top of the the rear fender whatever i try. I can tighten it down real tight but it seems to always work its way and it just starts to sag. Does anyone have a way to keeping the light in place instead of always starting to sag???
Personally, I've never had that issue with my CA taillight. However, if you search the forum, you will see that SEVERAL people have reported that problem.
 

·
Registered
Joined
·
102 Posts
I got my bike today and it was loose. i got it to snap in easy. just push the light back until it hooks on the latches. use JB weld's super glue to hold it. it's extremely strong glue from what i hear.
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter · #4 ·
i guess im going to end up having to epoxy something of some sort? I dont know what the deal is its screw in tight but that just doesnt hold the front point in it just sags. Maybe someone will have some sort of experience on here on have to fix that for good hopefully
 

·
Registered
Joined
·
110 Posts
use gorilla glue, do it soon because my lens just fell off while riding because its only glued on, if i knew that i would have taken the lens off myself and used gorilla glue, that shit is real strong
 

·
Registered
Joined
·
293 Posts
Man... iI have this problem on my bike too, it's so ugly looking. I bought my bike used so i think the previous owner crashed it and damaged the upper tabs on the tail. I've tried double sided tape and velcro, they work till the back end gets hot from the exhuast and after a ride my taillight is down again. I hope somebody here can suggest a good fix for this. Don't really want to superglue it though.
 

·
yut uuuuugh!
Joined
·
5,344 Posts
it has to due with forgetting to put a gramit (sp?), soft rubber fitting and taking it off your stock light and putting it on the new CA light. I did that with mine, but still had problems with it... so i used some clear silicone and you can't tell until you get close (I have a clear lens btw).
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter · #8 ·
im starting to think that some strong epoxy is going to be the best bet because you can screw the screws down as tight as you can get them and the front tip of the light still slowly comes down and sags and looks like crap. Im thinking on epoxing the thing and then leave it because you end up having to screw the the thing tight again every 2 weeks from riding.
 

·
Registered
Joined
·
18 Posts
mine had the same problem so where the two hols on the top of the lense are i replaced them with zip ties two up and two side ways to keeping in place and not moveing side to side and up and down and seems to be holding quite well had it since jan and i ride it 40 miles a day cant vibrate loose or sag so try that
 

·
Registered
Joined
·
1,118 Posts
CA (Clear Alternatives)

mine had the same problem so where the two hols on the top of the lense are i replaced them with zip ties two up and two side ways to keeping in place and not moveing side to side and up and down and seems to be holding quite well had it since jan and i ride it 40 miles a day cant vibrate loose or sag so try that
Either poor design or quality control, but let CA know and tell them it's defctive if your with-in your 1 year warranty and get them to send you a new one.

I had my last one glued into place. Which was fine till I wanted to change plastics. Now it has gunk stuck on it and won't mount flush on my other set. So I went with a VFX.
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter · #12 ·
yeah i cant get this thing to stay into place they stink. I think i need to look into getting a whole new light who knows.
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter · #16 ·
where can you get the vfx tail light. How does this thing differ from the CA one i have only had a CA never had a stock light so i dont know how that actually will be any better the whole design is horrible on these things. 2 screws then plastic at the tail its horrible they need a screw in the front or something.
 

·
Registered
Joined
·
1,069 Posts
Discussion Starter · #17 ·
that link not working for me i need to find a way of getting one of those lights tho
 

·
Registered
Joined
·
95 Posts
even with the rubber thing, i still have to work with it for a while to get it to stay in place
 

·
Registered
Joined
·
3,560 Posts
where can you get the vfx tail light. How does this thing differ from the CA one i have only had a CA never had a stock light so i dont know how that actually will be any better the whole design is horrible on these things. 2 screws then plastic at the tail its horrible they need a screw in the front or something.
VFX still utilizes the factory housing, you just open it up and replace the old circuit board. No fitting issues then. I've seen them in person and wish I had the money for one.
 

·
Premium Member
Joined
·
15,930 Posts
1 - 20 of 27 Posts
Top