Kawasaki Motorcycle Forums banner
1 - 8 of 8 Posts

·
Got lime? I do
Joined
·
16,736 Posts
Discussion Starter · #1 ·
well, i took my filter out to clean it today.
i was surprised at the amount of dirt built up in the "clean" side of the airbox.
so i figured the dam filter wasn't sealing good.
(btw, the rubber gasket i've never seen before lol)


anyway, while washing the airbox,
i noticed some major movement of this section
(didn't even know it was removable)


it also has a rubber seal all the way around it that does not seal anymore,
it even has a grove that it sits in. as you can see i sealed it up for good.
i don't understand why it was a separate piece,
but it had warped and was not sealed. therefore thats
where all the dirt came from ( a lot).

figured i'd pass this on just because i wasn't aware of it,
never heard of it, and your's too may be sucking dirt thru the crack.
this is an 04' zx6RR the rest of you guy's may have the same setup idk.
thats why i didn't put this in the 03'04' section.

sealed
 

·
Registered
Joined
·
32 Posts
K&Ns flow more air because the holes in the filter media are bigger. They rely on the oil film to grab the dirt. Problem is that it works better in theory than an airbox.

Visit a forum where people post & discuss oil analysis results, K&N filters always seem to cause high silicon numbers. The labs use silicon as an indicator of how much dirt is in your oil, as a result of poor air filtration.
 

·
Got lime? I do
Joined
·
16,736 Posts
Discussion Starter · #8 ·
yeah, you gotta keep them oiled good or they don't work well.
i've been using K&N on vehicles for years,
never had a problem like this, turned out to be warpage on that plastic insert
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top