Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello All,
Can you guys (and gals) help me out here a bit. I'm not sure if the LCD has always been like this but I just noticed last night: When I turn the ignition to the "ON" position and it does its test (tach scrolls all the way up and back down), all lights go on, I noticed that in the center were the speed is shown the first figure "8" is not complete but the second and third are. This would be where the "1" would be when you go over 100MPH. For all I know it has always been that way but since I just noticed I thought I would ask...or maybe part of my LCD has gone out.
 

·
Registered
Joined
·
261 Posts
Are you seriously suggesting that you would NEED your speedo to read 200,300 etc MPH. [?][?][?]

If your speedo is in MPH that is...if it is in kmh it is broken.
 

·
Registered
Joined
·
80 Posts
I'll just say the obvious..Even if it is in Km's do you need it to read 300 or 400 or 500 kms/h. Regards less..I would have it looked at. You bought it with the lcd working properly..so it should be fixed even though im may never read 800 mph...lol
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Just to let you guys know, I believe that if you check your LCD display on power-up, you will find that part of the first digit is also out. You are all correct in that you will never need that part of the display lit unless you do +400kmH. I checked my owners manual when I got home and the LCD picture in the book also shows it being out so I guess that's just how Kawasaki intended it to be. I also noticed that part of that "hundreth" place digit is also out in the temperature LCD display area.
 

·
Registered
Joined
·
3,119 Posts
That is pretty common. Almost all bikes with a digital readout will have the upper left hand corner light out on the LCD due to the fact that it is unneeded. Even if you were able to hit 300+mph/kmh you would still not need it until hitting 400+. Honda and Suzuki digital readouts work the exact same way. Haven't seen a Yamaha one on yet, so I'm not sure.
 

·
Registered
Joined
·
308 Posts
It is the same on other bikes as well. I was thinking though, that for the ZX-6R's, Kawi should have programmed it to read 636 on startup, that would have been cool. Just thinking out loud.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top