Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
i just changed my oil and filter and the oil gauge reads fine but my oil light wont turn off. i let it run for a few min and it still wont turn off. why is it doin this??? please help
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
thank you so much u saved my butt. im suppossed to go on a 2 hr trip 2morrow and this was not allowing me to sleep tonight. So i went out there and tried it and its just like new. Thanks alot bro Later
Dan
 

·
Registered
Joined
·
2,265 Posts
I've never heard of "burping" the oil filter but it does make sense and I don't doubt it would work.

The other thing that maight prevent this would be to prefill the new filter with oil before installing it. Keep the catch can underneath it while you thread it on for any that might spill out. I've been doing it like this and have not had the oil light problem.
 

·
Registered
Joined
·
383 Posts
I ususally just try to crank the engine a bunch of times without letting it fire up (short cranks, and if it fires, I kill it)
Never had a problem so far. A little throttle blip may be needed to bring up the oil pressure once you finally start the engine.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
all that stuff sounds good but this method worked so good so keep it in mind if u ever have this problem
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top