Kawasaki Motorcycle Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2007 Ninja 650R - purchased OEM stator and gasket - alls good - went to replace it back on the bike and now it doesnt seem fir fit properly. I read posts of how it sucks into the bike because of the magnet. Which it does BUT the bottom portion of the stator cover sucks right in and the mid to top part DOES NOT. Still has a gap. Ive re checked the gears and how I placed them and they match other posts with photos but still NOT sucking up against the main part. What am I doing wrong?? This is driving me nuts.
 

·
Registered
Joined
·
221 Posts
2007 Ninja 650R - purchased OEM stator and gasket - alls good - went to replace it back on the bike and now it doesnt seem fir fit properly. I read posts of how it sucks into the bike because of the magnet. Which it does BUT the bottom portion of the stator cover sucks right in and the mid to top part DOES NOT. Still has a gap. Ive re checked the gears and how I placed them and they match other posts with photos but still NOT sucking up against the main part. What am I doing wrong?? This is driving me nuts.

You are tightening the bolts in a star, pattern, right? Whenever your tightening something like that, you're supposed to tighten the bolts partially moving from one to the furthest away bolt so that you get things tightened evenly. That way, you shouldn't have the cover warp under uneven pressure on one side.



I'd remove it and verify that the cover hasn't becomed warped. I'd then make sure that the internal parts on the stator are properly seated before trying again.
 
1 - 2 of 2 Posts
Top