Kawasaki Motorcycle Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hey guys, well Im putting my bike back to stock, and sold the kit etc and kit tach, I put the old speedo and stock ecu on and the bike won't start, I got it with the kit stuff, does the stock ecu need something I don't have? it has a kill switch on the left bar which turns the ignition on, and the left starter switch assembley also has a kill switch which just kills it when its running, and the start button, the sidestand switch is wired together, there is no clutch swith wires going to the clutch, the bike cranks over but has no spark or fuel, just cranks and cranks... thanks!!! im a honda guy and am not sure what makes these kawis tick... btw its an 06 zx6rr.... thanks
 

·
Registered
Joined
·
123 Posts
Hey guys, well Im putting my bike back to stock, and sold the kit etc and kit tach, I put the old speedo and stock ecu on and the bike won't start, I got it with the kit stuff, does the stock ecu need something I don't have? it has a kill switch on the left bar which turns the ignition on, and the left starter switch assembley also has a kill switch which just kills it when its running, and the start button, the sidestand switch is wired together, there is no clutch swith wires going to the clutch, the bike cranks over but has no spark or fuel, just cranks and cranks... thanks!!! im a honda guy and am not sure what makes these kawis tick... btw its an 06 zx6rr.... thanks
What do you mean "left starter switch assembly." both the starter and the killswitch should be on the right. Were they relocated or something?
 

·
Registered
Joined
·
42 Posts
If it was a problem on the sidestand or the clutch switch the starter would not turn at all. Same thing with the starter button. Since it turns you should look for something else...
Immobilizer??? Any DFI errors????
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
immobilizer? does it have that? I don't have the ignition switch assembley, its been turned into a keyless bike...is that the problem??
 

·
Registered
Joined
·
42 Posts
If the ECU is from an immobilizer eqquipped 636 (European are for sure, US think not) then yes you have a problem. If not then no problem from there.
Does the FI LED on the meter blinks????
 
1 - 5 of 5 Posts
Top