Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter #1
My turn signals quit blinking, both fronts and rears.

Is this a fuse issue or are the signals wired in a way where should one of the turn signal bulbs fry, the rest of the bulbs involved in the circuit stop working as well?

Any help would be appreciated
 

·
Registered
Joined
·
945 Posts
Its probably a fuse, if one goes out that side will blink faster letting you know. Check the fuses, if its not that then start looking for melted wires somewhere. Mine shorted out once and kept popping the fuse....stupid wire came loose in the signal itself and was grounding out on the ground wire.
 

·
Resident Brit™
Joined
·
1,157 Posts
If you check the fuse first and it doesnt work check the relay which is between the toolbox and the bolt that holds the rider seat on.

Russ
 

·
Registered
Joined
·
270 Posts
Discussion Starter #4
Ok, thanks, I'll check for those.

I noticed when I left for work yesterday, when I fired it up, the blinkers worked, both left and right side, front and rears.
As soon as I drove away, short of a couple of minutes, they stopped working again.

Obviously this tells me there's something loose somewhere, a bulb perhaps or the fuse itself.

But once they stop working, they stop working altogether til I shut down the bike.

This morning when I rolled out, they were working again, then couple of minutes in, they stopped again.
Anyway, unless you guys have any other tips on what to check based on this newfound info, please let me know

In the meantime I'll go ahead and check the areas you guys kindly suggested.

Cheers,
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top