Kawasaki Motorcycle Forums banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
Guys, I'm sure some of you already know this. But for those who don't, here ya go. The FRAM PH6017A from your local parts store will fit your bike. No more expensive filter from the dealership. The FRAM is like 6 bucks. Way better than a dealership will charge for theirs. Hopefully someone will be able to use this tip. Peace out.
 

·
Registered
Joined
·
14 Posts
Have you tried this filter to make sure it works with the Z750S? I just had an oil filter problem with mine...dealer sold me one last year for my bike that has since been superceded in part number, twice. I didn't know this and put it on and my bike wouldn't make pressure, thus the oil light stayed on. I'm going to have trouble trusting the Kawa filter now, much less a Fram.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #3 ·
Well, I hate to have posted something that I have since learned is not good info. To begin with, my oil light came on when I put on the fram oil filter. I did the burp thing and it went out. I was riding my bike the other day and the light came back on. So, now that I have read the other post I feel that it is the fram oil filter that is the problem. So.....Now I have to go tho the dealership and get the filter I should have gotten in the first place.
 

·
Registered
Joined
·
14 Posts
Trial and error is still good information, at least I appreciate it. It will be a shame if we can't find a workable non-OEM filter. Just for reference, the current (latest of the supercedes) Kawasaki part number for the oil filter for a 2005 Z750S is:

16097-0004
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #6 ·
Thanks for the part number man, I plan on going to get one today. I should probably call them first to see if they have it before I make the 40 mile trip though. The z-1000 and the Z750s don't use the same filter do they???
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #8 ·
Well, just got back from the dealership with my oem filter. I screwed it on, checked the oil level, cranked the bike, the oil light started getting dim and then shut off after about 5 seconds. I reved the engine a few times and the oil light never eluminated. I think my problem is solved. A 15 dollar oil filter from the Kawasaki shop was the cure it seems. What a relief. Thanks for all the helpful info guys. I can't wait to ride again! Laterzzzzz!
 

·
Registered
Joined
·
26 Posts
I bought a K&N gold filter for my z750s and it has worked great. I was told that the K&N had more flow which gave a slight increase in power and was better for the engine. The only downside is that the price is $12 which is still close to factory price. I went to advanced auto and they ordered it in for no extra cost.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top