Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter #1
Hey all, this is my first post and I've been pretty lucky so far with any repairs or mods on my 6r. However, I recently put on a CA integrated taillight and broke off one of the tabs under the tail section fairing!!! F$#K Actually I loosened it when I put it on, and then yesterday it broke off when I sinched down a bike cover and it must have put to much pressure on a already weakened plastic tab! Dammit!!! Anyway, I fear that there is no solution, except the obvious, but I just thought I would ask. Any help would be much appreciated. Thanks guys.
 

·
DEATH TO THE ISA!!!
Joined
·
10,796 Posts
Do you mean one of the three tabs under the left side of the seat cover?

I broke one of those too while putting my seat cover back on after installing my CA integrated tail-light.

If it's one of those three, I'm sure you can pick one up for really cheap at a hard-ware store...don't think its a Kawi specific part or anything.

I had to go to the dealer anyway after I installed my tail-light and they fixed mine for free.
 

·
Powerhungry
Joined
·
37,962 Posts
im thinking he means one of the little tabs thats holds the light in place. if so SELL me your tail. if ofcourse u decide to replace it. and i believe thats going to be the only way to remedy that problem. aside from some sort of glue..and i wouldnt trust that.
umm after REreading the post. im not sure which it is...either way....
 

·
Registered
Joined
·
93 Posts
JB Weld, and a 12 pack of budweiser....fixes everything....i put my entire headlight back togeather with it, no leaks, and it works perfectly
 

·
DEATH TO THE ISA!!!
Joined
·
10,796 Posts
Originally posted by nevada
im thinking he means one of the little tabs thats holds the light in place. if so SELL me your tail. if ofcourse u decide to replace it. and i believe thats going to be the only way to remedy that problem. aside from some sort of glue..and i wouldnt trust that.
umm after REreading the post. im not sure which it is...either way....
haha i also broke one of those during installation [:p]

to the original poster - do you mean one of the two wellnuts in the seat cover? i broke one of those and trust me....they don't stay in place when you just stick them back in. the dealer fixed mine for me but im not sure what they did.
 

·
Registered
Joined
·
168 Posts
Discussion Starter #7
Yeah, it was one of those tabs that hold the light on to the actual tail section. Thanks to all who responded, I am gonna go out to the garage and try to solder it. Thanks
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top