Kawasaki Motorcycle Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
The problem:
When i try to start my bike it just keeps turning over and over. The battery is always at 12.something and is fairly new. The ignition switch the the positive battery cable runs to will click loudly and dim the lights while i try to start it. I have tested the rectifier (good) i have tested the generator (good) the battery while running is around 14v. When i throw a battery charger set to "55amp start" it cranks a few times and starts right away. When it is running and i rev the motor the headlight dims as the rpms increase.

My question?
Is there any correlation between the headlight and the ignition switch?
The starter sounds healthy and starts fine with the battery charger on it, could it still be the starter?
WTF else could be going on?

Thanks to all in advance.
 

·
Registered
Joined
·
148 Posts
You don't say which bike you have, is it a B?
Anyway lift the tank and check the resistance through the ignition switch between the white wire and the brown wire check it a few times, moving the ignition switch on and off. Short the miltimeter probs out and you should be looking at 0.2 Ohms on top of the meter leads shorted together.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
Sorry about the lack of needed info:

It is a 1998 zx9r.

I tested the rectifier today by putting the multimeter on the blak/yellow and white wire coming from the rectifier harness and i did not see the volts increase with the rpm's. It stayed at about 14v when the engine was revving.

My other question is would a bad rectifier have anything to do with the bike turning over a lot instead of starting? When i jump the battery with a charger it starts right up. Maybe it toasted the battery.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #4 ·
i put in a new rectifier/regulator from elecrtosport and the harness would not fit so they told me to cut the old one from my oem and solder it. I did and i guess the brown wire does not need to be used with the new rectifier. Has anyone else had to install this rectifier?
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #5 ·
please help!!!

Does anybody have any input please!?!?!?!

I have put in the stator and the rectifier. My bike is still hard to start unless the battery charger is jumping the battery. When it revs the headlight still dims. what is causing this? any help please!
 

·
Registered
Joined
·
1,905 Posts
Battery!! Change it
 
1 - 7 of 7 Posts
Top