Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
605 Posts
Discussion Starter #1
(Or anyone else who has installed a Two Brothers slip-on on a 2003.)

I read in some of your previous posts that you reused the stock midpipe/header gasket.

My question is: Did you use it so that the clamp would tighten securely? If so, did you have to spread the end of the s-bend pipe to fit over the gasket.

My problem is that the clamp is too large. When tightened all the way, it will roll around the s-bend pipe. As a temporary fix, I cut the gasket and wrapped it around the s-bend (already had everything together with sealant) so the clamp would tighten and hold.

I called Two Brothers and they gave me the part number for the clamp. I went home and checked, and it appears to be the correct clamp according to the part #.

Just wanted your input before I call them back.

Thanks in advance.
 

·
Registered
Joined
·
1,289 Posts
Hey what's up? Yes it makes it a tighter fit. The gasket should just slide inside the S bend. I mess up the first time around and forgot to put it in, then when I tightened down and had "loose" play, realized I forgot the gasket. That's when I had to re-widen the S bend (that really sucked). Did you put the gasket on the outside of the S bend? It should be inside the S bend, then slip on top of the header pipe so the gasket is in between the two pipes. I did notice that you have to crank pretty hard on the clamp. Because the end of the pipe has the two slots cut out (to allow for tightening), it's going to take a little effort to make it a snug fit. Almost feels like your turning it for a while. Hope this helps.
 

·
Premium Member
Joined
·
2,132 Posts
I installed a TwoBros. on my bike. The s-bend is not supposed to reuse the stock gasket. I called TwoBros. and they told I had the right clamp at first then the guy called back and said that they had anew spec number on the clamp(in other words the pipe comes with the wrong clamp.). The new spec. number is 27 61MSH. I
ga6rr has attached this file: p9300012.jpghope this helps. :)
 

·
Registered
Joined
·
605 Posts
Discussion Starter #4
Yeah, I found out the same thing.

When I first called TwoBros., they gave me a part# of 27-64MSH for the clamp.

Went home, double checked the clamp# (same as the number they gave me), called them back, then they gave me a new part# of 27-61MSH. The new clamp should be here in a day or two.

ga6rr, how do you like the pipe? I LOVE mine. Sounds freakin' AWESOME.

Were you in Albany during the '94 flood?
 

·
Registered
Joined
·
1,289 Posts
I reused the stock gasket, and the clamp that came with it and it fits just fine for me. No exhaust leaks either. So your saying that the you slipped the S bend directly over the header pipe (metal on metal), then cranked down on the clamp for a solid fit?
 

·
Registered
Joined
·
605 Posts
Discussion Starter #6
That is the way according to TwoBros.

They say do not reuse the stock gasket.

Apply the supplied sealant to the header pipe and attach the s-bend pipe with the clamp.

This was a problem because the clamp was too large.

There was either a packaging error, or they had the wrong clamp part# listed for the 636 (I suspect the latter since there are multiple cases of this happening).

Anyway, they have updated the part# to 27-61MSH.
 

·
Registered
Joined
·
1,289 Posts
Wonder if I should fix mine? It's funny that mine fit like a glove using the sleeve with the "wrong" clamp...Makes you go Hummmmm.......Did you have to send the other clamp back to them? If not, I just might get them to send me one just in case...
 

·
Registered
Joined
·
605 Posts
Discussion Starter #8
No, I did not have to send the wrong one back.

They sent the correct one via Priority Mail.

It just arrived while I was at lunch.

They (Two Bros.) did want me to go through the reseller, though. So I called Pipe City for them to handle it. No biggie, just one extra phone call. Guess that's how they track customer issues.

Anyway, both Two Bros. and Pipe City's service was very good.

BTW mred, thanks for the PM. The reason I didn't call you was that I was already in the process of working it out with Two Bros. at that time. But, thanks alot. It shows how members of this board are truly willing to help others.
 

·
Premium Member
Joined
·
2,132 Posts
I love it and yes I was in Albany in the flood of '94 and '98.
 

·
Registered
Joined
·
605 Posts
Discussion Starter #10
Got the new clamp on. Fits perfect. No gasket needed.

ga6rr, we felt for you guys when alberto went through. Hope you weren't affected too much.
 

·
Premium Member
Joined
·
2,132 Posts
Jlamb30 although I wasn't affected much I knew a lot of people who were but the flood showed me that there are a lot of good people in this world as I think pretty much the entire city pitched in to help family and friends. Maybe one day I'll ride to Valdosta and we can go for a ride together. :D
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top