Kawasaki Motorcycle Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
183 Posts
Check out powers stunt worx dot com and click on "gallery"

This is the gallery they post. The red railz on the Black/Grey GSXR look like they would be the right color. But the ones on the Yami look a little lighter.

Maybe give them a call and ask if the reds are different?

EDIT: On second look...the railz look the same color. I think one is taken outside. I think they would look good [:M10]
 

·
Registered
Joined
·
333 Posts
Hey I just ordered the same ones for the 06 SE...They told me that it is a real close match on the color...They tell me mine should be in early this upcoming week, so I'll put up some pix when I get them in...If you get yours before I put up pix, post some up there!
 

·
Registered
Joined
·
333 Posts
I received my railz today, but I don't have a dremel at my school so I'm going to have to wait a couple weeks til I can get it home to put them on...It looks like a pretty close match, I'll have to check it next to the bike though!
 

·
Registered
Joined
·
439 Posts
Here's what I learned from my mistakes:

Only take one stock motor mount out at once and immediatly replace it with the powers bolt with the rail inbetween.

Sand down the interior of the rail's holes so the silver mushroom/slider will fit.

The axle spools will not fit on the left side of the bike. I am in the process of sanding mine down. Powers offered for me to return it for one without the nub but I'd rather have the nub. I think a nub of slightly smaller diameter will do it's job way better than a spool withouit a nub at all.

Just my 2 cents
 

·
Registered
Joined
·
44 Posts
hey java i am having alittle trouble installing my race rails and i think the directions are wrong does the spacer go on the long bolt or the short? and which side does the long bolt go?
 

·
Registered
Joined
·
439 Posts
I forget, it's been a while.
But call Powers they will answer any question.

I know between the axle sliders and these rails I must have called 3 times.
 

·
Registered
Joined
·
569 Posts
Originally posted by usmc636
ok, i finaly got mine in and instaled. will have pics soon. anyhow i have these two little mushroom sliders that came with it, does anyone know where thes go?
sounds like those are the spools for your rear axle... aka axle spools... i could be wrong though:D
 

·
Registered
Joined
·
439 Posts
the mushrooms go in the holes in the front of the rails.

First you need to sand down the inside of the rails' holestill you can silde the shrooms in. ( mushrooms' bolt must be loosened)

Second slide the mushrooms in and tuighten them so the bevel cut on their shaft bites the inside walls of the rails.

That should do it.
 

·
Registered
Joined
·
333 Posts
Here's my bike with the railz!
 

·
Registered
Joined
·
333 Posts
It's damn near a perfect match!
 

·
Registered
Joined
·
927 Posts
I have a set myself, but after a while they seem to snap at the hinge towards the back. I dont think they were welded probably in that area. A few people have been having problems with this.
 

·
Registered
Joined
·
439 Posts
Greenreeper, I have never heard of this.
Have your rails started doing this?
Do you know of any pictures that show this issue?
 
1 - 20 of 20 Posts
Top