Kawasaki Motorcycle Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I have an issue with my bike running hot and the fan not turning on every time. I would appreciate any help since the closes Kawazaki dealer is quite far, and I am not even sure how good they are.

The bike is ZX6R - B2 (2004year)

I noticed that the fan on the bike doesn’t turn on every time. I would be sitting at the traffic lights the temp gauge will show 107C (224.6F) and the fan won’t be on. If I turn the bike off the fan starts (not aways) but most of the times. Then there will be days where it will turn on with no problem.

What I did is to check the fan switch on the radiator with a multimeter, everything was OK, and the fan turned on while i just let the bike run on the side stand. Few hours later I go for a ride and the radiator fan didn’t turn on.

So I am wondering can it be a faulty switch that is playing up or is there something else that can be broken?

Thanks:|
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
When the coolant temperature goes up beyond 92∼104°C (198∼219°F), the radiator fan switch conducts to operate the radiator fan...

Its possible the water temp sensor is faulty or has a loose connection?

You mean the sensor at the engine block, right? Not the one at the radiator?
 

·
Registered
Joined
·
41 Posts
it shouldnt take you an hour to get to the sensor all you need is an allen wrench and 10 mm socket to get the tank and seat off then you need a philips to remove the coolant res if it may be in the way and i think its an 17mm or a 19mm deep well to get the sensor itself removed from the block should run you about 100$ for the sensor the fan should kick on around 200 or 220 mine only kicks on at an idle or at red lights in traffic it could could be just a single pin in one of the connectors just getting a bad connection and not the sensor you can look into repining your conectors or just tweek the pins with a pair of plyers and make sure they are getting good conection and fill the conectors with dielectric greese
 
1 - 7 of 7 Posts
Top