Kawasaki Motorcycle Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I gotta 2005 ninja 636 and I ride for about a hlf hr to hour thn I give it throttle then it completely dies out i let it sit for 5 to 10 min thn starts up an act like nuthn happn thn does it again 20 min latr someone please help me because I'm tired being stranded on side of the road thnk you
 

·
Registered
Joined
·
3 Posts
hey man. I got the same issues. Did some research and it seems like it’s an overheated ECU. I bought a used one and I’m getting it on Thursday. I’ll install it same day and let you know how it goes.
 

·
Registered
Joined
·
3 Posts
Hey. I installed the ECU and no more shutting down. I usually get around 22-24 miles before it would shut down and I drove just over 30 today after the install and everything worked perfect. Sunday I’m taking it out for a 50 mile plus ride so thatlol be the real test. My bike is an 05 and I got an ECU from an 06 which was recommended from people in threads when I was doing research. Good luck with your bike.
 

·
Registered
Joined
·
672 Posts
I gotta 2005 ninja 636 and I ride for about a hlf hr to hour thn I give it throttle then it completely dies out i let it sit for 5 to 10 min thn starts up an act like nuthn happn thn does it again 20 min latr someone please help me because I'm tired being stranded on side of the road thnk you
Yes..ECU without a doubt. I had same trouble, long story short, replaced ecu about 8 years ago now, haven't had a problem since. Also, I wrapped the pipe under where ecu sits to help dissipate some heat, drilled a few small holes in the plastic chamber where it sits....no problems at all since.
 
1 - 9 of 9 Posts
Top