Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
466 Posts
Discussion Starter #1
anyone have any issues with their slipper clutch malfunctioning under decel?
At Cycle James (Road Atlanta) my bike started acting up. bike would stutter/hesitate if I carried third gear into any corners (not on gas). so I started carrying either 2nd or 4th gear thru corners instead. bike had no problem under power, clutch wasn't slipping under power. I soon started experiencing the same in 4th gear as well and the bike became hard to shift (clunk clunk) so I pulled off the track. Later I found a couple bent shift forks & rounded gears. Replaced the shift forks, gears, shift dogs and bike ran fine at Barber for a good 40-50 laps in practice and then started stuttering again under decel. I know Kawasaki uses some soft metal, but I can't see it being the shifter forks/gears again. I think the bent forks and rounded gears from RA were from me pushing it while trying to work through the problem. Do I replace the plates or are the springs to blame? Anyone experience this problem and can offer a solution. trying to permanently fix bike before GNF in 2-3 weeks.
 

·
Registered
Joined
·
1,354 Posts
That SUCKS. The slipper really is basically a standard clutch with a cammed back plate that disengages it. I have not had a shifting problem on my 03, but I did have to replace the fibers and steels once at low mileage. And used barnett springs for that install. Keep us posted.

The only thing that comes to mind is either your steels are warped or the outer basket is so badly notched it holds the plates.

Good luck

Ernie
 

·
Registered
Joined
·
466 Posts
Discussion Starter #3
checked the fibers and they are in spec, the steels aren't warped. the spring washer looks fine as well. this only happens off throttle, not on the gas and it didn't start again until 50 laps into Barber
 

·
Registered
Joined
·
78 Posts
Even though you replaced the dogs and stuff on the trans it honestly sounds like a tranny issue. Mine would do the same thing before I put a complete 05 unit in my 03. I put both input & output shafts, all the new gears, shift drum, shift star (more aggressive than the factory pro unit but has to be used with the 05 shift drum) and factory pro detent arm and spring. And of course the 05 slipper clutch. While it was appart I also shimmed it per the factory kit manual. I have yet to have a issue with it since and I've been pretty hard on it.
 

·
Registered
Joined
·
554 Posts
I think you should try Factory Pro's Shift Star, Detent Arm, and Spring kit. And when you miss a downshift always try upshifting before forcing a downshift. I also no how lazy these slipper clutches make us, but still try and blip the throttle. Every Kawi I have owned had a problem shifting up from 4-5th and down from 2nd-1st if I got lazy. When I say lazy I mean not preloading my upshifts and not blipping and feathering the clutch on downshifts. I don't like to drop more than two gears without a quik feather to make sure the gears are engaging. The Factory Pro kit has fixed this problem every time among other benefits. Everything but my lazy ass.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top