Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
broke the spring on my brand fuckin' new tbr slip on. think they would send me a new one. still have the other one in place, think i need to worry about it at all? also there is a slight air leak, and i mean i have to search for it, where my s bend connects to the stock exhaust, is this ok or should i seal this shit with more high temp sealant. pipe sounds amazing. i have a boy with a hindle, and m4 and a d&d and they all say mine sounds like a real bike should. so i recommend tbr. thanks 6r's
 

·
Registered
Joined
·
1,289 Posts
Did you break the spring during install? Just give the m a call, I'm sure they would hook you up. I would go and buy some more sealant and reseal the whole connection. After I goofed the first time, the second time was easy (I forgot to pull the graphite sleeve out of the stock pipe and the sealant dried on me).:D
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
hey mred did you take it apart and reinstall with the sleeve or just put more sealant on it to seal it up? im hesitant to take it off cause i think i might have stripped the bolt a little and dont wana fuck with it. think ill be ok or should i say fuck it and take it apart and put the sleave in this time?
 

·
Registered
Joined
·
1,289 Posts
Did the new pipe have 2 slots cut in it at the end (for tightening so the pipe would hold for a tight fit)? Did you already crank down on it? If so, and you want to use the sleeve, you will also have to find a way to make the pipe end (S bend) bigger to accept it for re-mount. I tried at first without it, and it didn't seem right. Then I saw the sleeve stuck in the stock pipe that I had just taken off. I reused the sleeve, and the sealant. I would think it's a must. Someone please correct me if I'm wrong.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top