Kawasaki Motorcycle Forums banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
303 Posts
Discussion Starter · #1 ·
a couple nights ago i was riding with a buddy.. whenever i would nail the throttle and take it up to high RPM's it would stumble bad.. it loses all power at like 12,000 - 12,500.. i dont know if its jetting but its completely stock.. the bike just started doin this that night... just thought i'd see if anyone knew whats wrong. thanks
 

·
Registered
Joined
·
321 Posts
Sounds like you described exactly what my bike started doing two days ago. I haven't really had a chance to check it out. But just before I noticed it, I had filled up on gas at an unfamiliar station. I'm gonna run this tank dry today, and go from there. I've got about 6,500 miles on mine, so I think I'm due to change the plugs, and clean my air filter. I'll let you know what happens, and vice vesa.

I'm a recovering work-aholic, and I haven't done a damn thing for 6 months.
 

·
Registered
Joined
·
303 Posts
Discussion Starter · #5 ·
no it doesn't rev up, it does the opposite.. it stops and makes no power.. its like your hittin the rev limiter at 12,000 rpm.. and it only does it when i twist the throttle hard.. if i just gradually take it to redline it does it.. but when i get on it hard it stops.. its fucked up.. i dont know whats wrong with it
 

·
Registered
Joined
·
303 Posts
Discussion Starter · #9 ·
thanks for the suggestions guys.... i just drained the tank so its not gas... i'm gonna pull the plugs and check the gap and leads.. thanks again.. i'll keep ya'll posted
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top