Kawasaki Motorcycle Forums banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter · #1 ·
There is a really long thread about this on here, but kkim suggested making a more concise thread so you won't have to read the whole other thread. Basically, if your tachometer reads different rpms at the same speed/gear when it is hot or cold, it is a problem with the tach and it is not normal. Kawasaki is replacing them under warranty. Don't let the dealers jerk you around. If they are, they are not a good dealership. Here is what I wrote in my last post in the other thread on this topic:

Everybody on here with this tach issue...If your dealer is BS'ing you and saying it's normal, then take matters into your own hands. Good dealers will fix it no questions asked like mine did. It is a known problem with these tachometers and Kawasaki knows it. They are replacing them under warranty. Call Kawasaki's 800 customer service #, get a hold of the correct person, and tell them what the problem is and what the dealership is telling you. Get the dealership in trouble. And then find a different dealership to do business with.
By the way, when I took my bike in (the FIRST time), he called Kawasaki while I waited, then immediately ordered a new tach (under warranty) and told me he'd call me when it came in. The next week, he called. I dropped my bike off on one day, and it was ready the next working perfectly. END OF STORY!! That's how it should be.


I hope this helps some of you.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top