Kawasaki Motorcycle Forums banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
K - my whole stalling above 5 grand problem is slowly getting better. This weekend, I changed the plugs (which were terrible), fixed my fluid level problems, drained the old gas and added all new, and took it out again. It was a descent temp out (around 50 degrees)and it seemed to do a bit better.

Riding in 1st gear, I can hit about 8 grand and then it will just seem like it loses power, almost as if it is not getting enough gas. 2nd gear is about the same around 6 grand now. I got some balls (or call it stupidity) and cracked the throttle a litte more once it did this in second, and it felt like it wanted to go, almost like "jumping" forward quickly then letting up, so I let it do this for about 10 seconds and it slowly started to accellorate smoothly then. As I went thru the gears, the same problem occured, just at lower RPM's. Maybe it is due to the new gas that it is getting better, or just because it sat for a while it needs to be ran a bit to "clean it out" but it does seem to be getting better. Just in case it is a fuel delivery problem, what should I do to check that out? I have a new filter on order right now, but what else can I do?

Naz :cool:
 

·
Registered
Joined
·
4,213 Posts
if you think you had bad gas in your bike, i would change out the fuel filter. the filter holds back "the bad stuff" and it could be backed up as well......thus bad fuel delivery and pressure.

Vin:"I live my life a 1/4 mile at a time"
Arturo:Hahahahhaha...Why?
 

·
Registered
Joined
·
70 Posts
Discussion Starter #3
It is getting WAY better now. Hit 9 grand today, and the adreniline was awsome. The bad gas must have been the culprit.

Naz :cool:
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top